Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Can't start Chapter 9: The Eternal Throne

STAR WARS: The Old Republic > English > New Player Help
Can't start Chapter 9: The Eternal Throne

DrinkableEwe's Avatar


DrinkableEwe
08.05.2018 , 06:05 PM | #1
Made a boosted character to start the expansions and whenever I click play it just takes me outside of the odessen base thing and nothing happens not sure what to do as I've completed the other chapter. help would be appreciated



EDIT: don't know what fixed it but it is working now idk how to close the thread

Dragondog's Avatar


Dragondog
08.06.2018 , 12:39 AM | #2
Some of them start that way and you have to go inside on your own. I don't remember if that chapter is one of those, but you could try that.
SWTOR Referral Link for new and returning players. Add 7 days of SUBSCRIPTION and other good stuff.

DrinkableEwe's Avatar


DrinkableEwe
08.06.2018 , 01:36 AM | #3
Yeah I've tried that and nothing happens and theres no kind of quest marker it just says press play to start the chapter and it just sends you outside. Everything I've seen and read says the chapter starts with a cutscene

GeoffBlack's Avatar


GeoffBlack
08.20.2018 , 12:19 PM | #4
As the chapter starts to launch press alt/f4. It will close the game. When you come back in, you will be able to launch the chapter. This worked for both my wife and me.

jonathanmagnus's Avatar


jonathanmagnus
02.10.2021 , 07:06 AM | #5
Just want to bring this topic back up again! This problem still persists as me and my friend are trying to continue on with our story and the alt f4 during load doesnt fix the issue, neither does resetting phases, changing graphics to low, launching from different locations. I've tried almost anything I've been able to think of! Anyone know a current fix?

MrDelvan's Avatar


MrDelvan
02.21.2021 , 07:05 PM | #6
Ran into this too, the alt-f4 trick didn't work. Turned out, I needed to leave the group I was in, start it solo, then reform the group via chat once inside, then eventually got the character portraits that would allow sending a transport to story quest invite to my group member to continue forward.

IINXGANII's Avatar


IINXGANII
08.01.2021 , 04:58 AM | #7
The thing same still happened on me right now. I can't launch the chapter. When I clicked it, it just spawned me at alliance landing,Odessen