Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

[Synthweaving] Craftable robes issue! SWTOR please fix!

STAR WARS: The Old Republic > English > Crew Skills
[Synthweaving] Craftable robes issue! SWTOR please fix!

DeZanzibar's Avatar


DeZanzibar
06.26.2022 , 06:01 PM | #1
So I discovered a new bug for all players who are now Sith Warrior's and are also crafters. If you play Sith Warrior as a Sentinel, Sage, etc. You wont be able to wear "Sith Dueling Leathers". In the bottom it says "Requires: Sith Warrior, Imperial Agent". I tried to wear it with my new Sith Warrior Sentinel but it is not working. SWTOR, please fix this issue. All Sith Warriors should be able to wear this. It's not Sith Dueling Leathers alone that is having this issue, it's many other craftable items as well.

SteveTheCynic's Avatar


SteveTheCynic
06.27.2022 , 03:40 AM | #2
This situation applies to all items locked to a particular "class" or list of classes, without reference to how it's obtained. You have to be using a Combat Style that used to be linked to the given "base class" before 7.0. (Note: it says, "Requires Sith Warrior", not "Requires Warrior". The Warrior origin is not *Sith Warrior*.)

The only real "fix" for this issue would be for them to make all such items *not* class locked. The weight class is less of a problem, since Outfitter doesn't care about weight classes, but it still cares a *lot* about class locks.
Something you find difficult is a lesson on how to play better, not a punishment for playing badly.
To go to Belsavis, you must go to Belsavis.
Latest patch notes at http://www.swtor.com/patchnotes

DeZanzibar's Avatar


DeZanzibar
06.27.2022 , 08:21 AM | #3
They should do that then, outfitter shouldn't matter what skin you wear. I don't mind not wearing it for my gear but... for outfitter it creates this issue. They need to fix this.

SteveTheCynic's Avatar


SteveTheCynic
06.27.2022 , 09:21 AM | #4
Quote: Originally Posted by DeZanzibar View Post
They should do that then, outfitter shouldn't matter what skin you wear. I don't mind not wearing it for my gear but... for outfitter it creates this issue. They need to fix this.
Indeed. People have been commenting on the lack of support for wearing class-locked gear in Outfitter and its predecessor 'Outfit Designer' for almost as long as Outfit Designer has been available in-game.
Something you find difficult is a lesson on how to play better, not a punishment for playing badly.
To go to Belsavis, you must go to Belsavis.
Latest patch notes at http://www.swtor.com/patchnotes