Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Reclaimed Treasure Bug - Deshade doesn't appear in Hidden Hollow

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
Reclaimed Treasure Bug - Deshade doesn't appear in Hidden Hollow

Tolkyyn's Avatar

04.06.2016 , 10:15 AM | #1
My character has gone in and out of the hollow. He has logged out and in. No Deshade. I did this without a problem on another character, so I don't know why this is broken for my Sage.

Tulmara's Avatar

04.06.2016 , 12:43 PM | #2
Can confirm, the same just happened to my smuggler, had to reset the quest chain to get it to work. Also exiting to Hidden Hollow kills you with falling damage ... intended ?

Tolkyyn's Avatar

04.06.2016 , 08:18 PM | #3
What a pain. I don't think it's worth it for my Sage, he'd just refuse the companion anyway.

SerraShar's Avatar

04.07.2016 , 04:44 AM | #4
I like to add that for me , tried this mission on my Sorc . And I can't even get there .

Got the Talisman . Then went Outside to get the Victory stone . Came back . Put them in Order (without space baring anything) . Using Talisman and NOTHING HAPPEND .

Tried it 10 Times . Relogged , Reset . Abondoned . Traveled elsewhere . And still Nothing .

Me and a guy , both of us been standing there trying again and again . Well he was able to teleport at least . I aint even gotten there .

Was using Delfy walktrough as well in case I did something wrong :

EDIT: Turn out I was missing a step . Customer service contacted me , and I was able to finish the quest . Hopefully , they will be able to fix yours . All the best to anyone who still has trouble with this quest .

Jaden_Soro's Avatar

04.23.2016 , 08:27 AM | #5
I've recruited Talos through conversation as an inquisithor. But mission "fighting power with knowledge" is still on alerts list hence cannot proceed for reclaimed treasure.

AnitaBlue's Avatar

05.20.2016 , 04:42 AM | #6
I had the EXACT same issue... my advice: don't waste your time, just RESTART the quest and do it over. The good news is it'll take you just 5 minutes, since you know what to do now.

As others pointed out, logout and login again doesn't work.

Atlan_Vox's Avatar

05.29.2016 , 05:47 PM | #7
still happening i have reset the mission going on 10 times now i got into the cave no deshade follow the same steps even getting the tablet from outside got the medallion placed all the tablets in order like i did the first time got teleported but no deshade now its saying touching the medallion to artifact does nothing very disturbed by the lack of progress had same issue when trying to recruit the jawa had to reset the mission 5 times for it to take hold this time iam going on the 10 reset

Lialiten's Avatar

06.20.2016 , 03:49 PM | #8
Same problem here. No Deshade.

Piepyr's Avatar

08.06.2016 , 05:44 PM | #9
Can't complete this either. Why the **** is this still a thing?
Level Sync: Another way of saying, "We don't want to spend the time or the resources to create new content."

saradominn's Avatar

06.13.2017 , 10:54 AM | #10
thats the same on me....