Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Sound issues/Problèmes de son

STAR WARS: The Old Republic > English > Community Content
Sound issues/Problèmes de son

Dufman's Avatar


Dufman
03.06.2021 , 08:19 AM | #1
Hi everyone,

I don't know if this is the right place to ask for help but customer's assistance was not usefull at all.

I built a new PC last week and made a huge upgrade (old PC bought in 2011).

Since I reinstalled the game SWTOR on my new PC, I had a bad surprise because all sounds were muted in both launcher and game.
I checked my PC configuration :

- sound mixer is activated for SWTOR
- all drivers are up to date (latest version)
- sounds are ok in other applications or games
- "Ctrl" + "S" doesn't fix the issue (just switches tick box from fulfilled to empty)
- I tried to fix the installation twice with tool available in the launcher and it did not fix the issue
- I tried a solution proposed by customer's assistance (an exe file LauncherRepairUtilityU2021.0.18) and it did not fix the issue.

Here is my PC set up (I put everything, I don't know what could cause this issue) :

OS : Windows 10 (64 bits)
Motherboard : ASROCK B460 PRO4
CPU : Intel(R)_Core(TM)_i5-10400F_CPU_@_2.90GHz
GPU : NVIDIA GeForce GTX 1050 Ti
Sound card : Realtek High Definition Audio
Headset/Microphone : Razer Kraken 7.1 Chroma

Is there someone to have an idea about how I could fix this issue ?

SteveTheCynic's Avatar


SteveTheCynic
03.06.2021 , 09:39 AM | #2
Two things spring immediately to mind:
* Is the sound for SWTOR turned all the way up in the Windows mixer? (Same for the mixer's master volume.)
* Does the headset have an in-line volume control, and if so, is *it* turned up?

I ask these things because I've had problems with both of them in the past.
Something you find difficult is a lesson on how to play better, not a punishment for playing badly.
To go to Belsavis, you must go to Belsavis.
Latest patch notes at http://www.swtor.com/patchnotes

Dufman's Avatar


Dufman
03.06.2021 , 12:12 PM | #3
Thanks for this information that could help other people.

Unfortunately, the sound mixer is always up for SWTOR and my headset does not have a function to manage the volume on it.
I tried also to open the game as administrator (no effect), with compatibility with 7 or XP (no effect).
I really don't understand why this damn sound is still off in the game whereas everything is on everywhere

Dufman's Avatar


Dufman
03.06.2021 , 01:56 PM | #4
And I finally found the solution...

I just deactivated in Windows my screen and Realtek card as sound devices to just let my headset on...
Apparently, even if I choose my headset as sound device by default... SWTOR still send the sound to another device...

That's dumb... but I can now play with sound.
I did not have this issue with Windows 7 and it seems for Windows 10, this action can fix the problem.
I hope this will help other people.

SteveTheCynic's Avatar


SteveTheCynic
03.07.2021 , 03:23 AM | #5
Thanks for telling us that it's fixed, and what you did. And yes, the Windows audio subsystem is a bit messed up. I remember having my headset's microphone as the default in Windows 7, but when I let it upgrade to Windows 10, the upgrade *changed* the default to be my Rocksmith cable, which was a bit of a problem when I first tried to use Mumble afterwards.
Something you find difficult is a lesson on how to play better, not a punishment for playing badly.
To go to Belsavis, you must go to Belsavis.
Latest patch notes at http://www.swtor.com/patchnotes