Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

FPS Drops in PVP ~ Unplayable

STAR WARS: The Old Republic > English > PvP
FPS Drops in PVP ~ Unplayable

swtorirukandji's Avatar


swtorirukandji
01.12.2022 , 09:51 PM | #1
So I've done everything to fix it, its literally only this game that I get FPS drops in. I'm guessing its a normal thing? As everyone's saying they get it too sometimes. Or is there some kind of fix to the FPS issues?

Rion_Starkiller's Avatar


Rion_Starkiller
01.13.2022 , 01:12 AM | #2
You can turn off nameplates and flytext to help mitigate FPS loss, but it’s definitely not a cure all.
Beruhl (ง︡'-'︠)ง ~ ADAL-IstyanFiend
8 pugs and a grophet Show Me Your Rage
Quote: Originally Posted by Trolltar View Post
I believe he's quoting a frequent contributor to these forums. His name is Strawman.
Quote: Originally Posted by Lunafox View Post
Thanks Rion Starbrah.

TrixxieTriss's Avatar


TrixxieTriss
01.13.2022 , 02:41 AM | #3
Quote: Originally Posted by swtorirukandji View Post
So I've done everything to fix it, its literally only this game that I get FPS drops in. I'm guessing its a normal thing? As everyone's saying they get it too sometimes. Or is there some kind of fix to the FPS issues?
I’m guessing you’re also playing from Australia with a name like that.

The only thing that’s worked for me is turning off bloom and shadows entirely, reducing the ground clutter (trees and grass to 20%) and turning off as many names plates as you comfortably can and still see what’s going on. Also turning down some of the other setting is advisable if your not running a top speed CPU (over 4.1ghz) and GPU.

Another thing I recently came across on Reddit that seems to help with FPS drops anywhere is this : https://www.reddit.com/r/swtor/comme...tm_name=iossmf

I’ve tested on my i7 7700k CPU and it works just as well on AMD CPUs too.

swtorirukandji's Avatar


swtorirukandji
01.13.2022 , 10:49 AM | #4
Quote: Originally Posted by TrixxieTriss View Post
I’m guessing you’re also playing from Australia with a name like that.

The only thing that’s worked for me is turning off bloom and shadows entirely, reducing the ground clutter (trees and grass to 20%) and turning off as many names plates as you comfortably can and still see what’s going on. Also turning down some of the other setting is advisable if your not running a top speed CPU (over 4.1ghz) and GPU.

Another thing I recently came across on Reddit that seems to help with FPS drops anywhere is this : https://www.reddit.com/r/swtor/comme...tm_name=iossmf

I’ve tested on my i7 7700k CPU and it works just as well on AMD CPUs too.
I live in Austin, TX xD

And I appreciate it! I'll give it a shot.

abhaxus's Avatar


abhaxus
01.26.2022 , 09:05 PM | #5
When you say "FPS drops - unplayable" is the game coming to a screeching halt in warzone instances, like actually 0 FPS for multiple seconds? If so, you might be experiencing a bug with your sound driver. I've found if you connect a USB sound device after SWTOR has started, you will get this unplayable lag in game until you completely restart.

It happens for me if I connect my SoundblasterX X5 USB sound card after SWTOR starts. It's also happened for me when i connect an HDMI sound device after the game starts. For some reason it does not happen with the USB dongle for either of my headsets (Razer and Logitech).

Other than the soundcard, even with a pretty legit PC you'll get drops down to about 25 FPS in warzone - my i5 10600k + GTX 1650 Super drops that low despite low GPU utilization, and my laptop with a Ryzen 7 5800H and RX 6700M also drops to around 20-25 FPS in really heavy cleave.

Kinda funny that I can run Crysis Remastered in "Can it Run Crysis?" mode (with ray tracing off) at double the FPS i get in SWTOR.
Abhaxus - Sorc | Bitter Pill/Lysol Injection - op | Buubi'sett - PT | Nnnoooooooooo - Jugg | Mayor Bootyjudge - sniper | Juggsridemelikeapony - Merc | Goodagainstbads - sin |

TrixxieTriss's Avatar


TrixxieTriss
01.27.2022 , 05:24 AM | #6
Quote: Originally Posted by abhaxus View Post
When you say "FPS drops - unplayable" is the game coming to a screeching halt in warzone instances, like actually 0 FPS for multiple seconds? If so, you might be experiencing a bug with your sound driver. I've found if you connect a USB sound device after SWTOR has started, you will get this unplayable lag in game until you completely restart.

It happens for me if I connect my SoundblasterX X5 USB sound card after SWTOR starts. It's also happened for me when i connect an HDMI sound device after the game starts. For some reason it does not happen with the USB dongle for either of my headsets (Razer and Logitech).

Other than the soundcard, even with a pretty legit PC you'll get drops down to about 25 FPS in warzone - my i5 10600k + GTX 1650 Super drops that low despite low GPU utilization, and my laptop with a Ryzen 7 5800H and RX 6700M also drops to around 20-25 FPS in really heavy cleave.

Kinda funny that I can run Crysis Remastered in "Can it Run Crysis?" mode (with ray tracing off) at double the FPS i get in SWTOR.
That reddit post I linked actually really helps with FPS drops and smooths out game play better than not using it.