Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Can't log into DM, World loading. Stuck on character screen

STAR WARS: The Old Republic > English > General Discussion
Can't log into DM, World loading. Stuck on character screen
First BioWare Post First BioWare Post

Nightblazer's Avatar

06.24.2020 , 12:27 PM | #11
Quote: Originally Posted by Glavnii_jeday View Post
Do not help. Same issue "Download 0%"
You tired both guides for the suck at 0% and switching to the non streaming launcher?
“PATIENCE YOU MUST HAVE my young padawan”

– Yoda

Teaurn's Avatar

06.24.2020 , 12:56 PM | #12
Quote: Originally Posted by Nightblazer View Post
Your update miss stuck at 0%. Try the steps here.

If that doesn't work, try switching to the non-streaming launcher as per here. It is what I use and never have issues patching.
Does not help this issue. Tried it. Thanks.

ljurek's Avatar

06.24.2020 , 01:04 PM | #13
Same issue unfortunately. I tried to repair game install, delete bitraider, BitRaider Mini-Support Service state change.
Doesn't work. Should I download the game again or just wait for fix?

Hans_bach's Avatar

06.24.2020 , 01:04 PM | #14
Ah a bioware patch day and all i get is this Quick Play mode, only starting world planets. What did you brake now Bioware. fix 1 thing brake everything else

KarathAnno's Avatar

06.24.2020 , 01:20 PM | #15
Same issue.

I was able to log in after the servers came back up but now all my character that are not on a starting world cannot be played and it says I have to wait to download the game again.

Nathan_Hanefort's Avatar

06.24.2020 , 01:22 PM | #16
On DM forum I saw 1 guy stated, the he deleted bitraider, unistalled the game and reinstalled - it worked for him. I will try this myself - first time I only deleted/reintstalled the game, now I removed Bitraider via "add or remove programs", properly and downloading full game again.

Never experienced anything like that and playing for years. Just omg. WoW launched in 2005, still, after 15 years and SpeceX lauching private rockets, we have crap like this going on.

alphamalebsr's Avatar

06.24.2020 , 01:32 PM | #17
Quote: Originally Posted by Nightblazer View Post
You tired both guides for the suck at 0% and switching to the non streaming launcher?
I tried both and NADA.. Still stuck at 0% loading and can only play on starter worlds...

The fact that this happens to so many makes me wonder do they even test these patches?....

Hoplop's Avatar

06.24.2020 , 01:54 PM | #18
I do NOT use bitraider...haven't for many years, yet I too have problems. After the long patch and hitting "play" the client went on to the loading screen. Then I drop to desktop. I've used the repair option on my 3 additional attempts but without success. The last character I used yesterday was on DM.

I don't even get as far as the server select screen before I crash. Everything was fine before this patch. What's going on?

CommunityTeam's Avatar

06.24.2020 , 02:09 PM | #19 This is the last staff post in this thread.  
Hi folks,

Thanks for the reports concerning the issue with the Character Selection Screen.

Our team is currently looking into it. I will let you know when I have more information about it.
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.]

Hans_bach's Avatar

06.24.2020 , 02:11 PM | #20
Okay fixed the problem, did the following from:

"close the launcher, right mouse click on the game shortcut, select open file location and delete the BitRaider folder.
Then start the launcher"

did that and now I'm back in. cooler head also helped, this thinking part is painful