Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

The Login Service Is Currently Unavailable.

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
The Login Service Is Currently Unavailable.

Battosie's Avatar


Battosie
02.21.2020 , 05:23 AM | #1
hi returning player/founder/subscriber, can't login just keep getting error message " the login service is currently unavailable. please visit out Forums for the latest updates on the server status of this service". cant find anything on this tried launcher repair utility, tried reinstalling game, nothing seems to be working cant even patch it because i can't login. servers are all up and i can login to site so Help please.

Krinji's Avatar


Krinji
02.21.2020 , 11:17 AM | #2
Hi,

Could you try to open CMD and execute

ipconfig /flushdns
Darth Krinji
Proud owner of Collector's Edition
Free 7 days of sub

Battosie's Avatar


Battosie
02.21.2020 , 06:02 PM | #3
hey just did that thanks for the tip but it didnt work , just wont let me login to update/install game

OwenBrooks's Avatar


OwenBrooks
02.21.2020 , 08:14 PM | #4
This is the bug report forum for ingame issues, Tech support is at https://answers.ea.com/t5/Technical-...ld-republic-en

start with your antivirus and firewall

Battosie's Avatar


Battosie
02.21.2020 , 10:05 PM | #5
yeah mate done all that already it is a bug thats why its here and ontop of that been on support theres nothing on why this is happening

OwenBrooks's Avatar


OwenBrooks
02.22.2020 , 01:34 AM | #6
Antivirus/ firewall blocking or you can not ping launchpad.swtor.com (net routing issue) are usual causes of login is unavailable

ESET - disable "protocol filtering"
Kaperskey - disable "scan secure/encrypted connections"
Norton (Firewall) - set exceptions to "Allow" not "Auto"

this is not a bug for the bugreport forum per the top sticky https://www.swtor.com/community/showthread.php?t=877258 launcher issues should be posted in technical issues forum there is no CS available in the bug report forum.