Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

I can't complete the download/installation of the game

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
I can't complete the download/installation of the game
First BioWare Post First BioWare Post

Pseudolo's Avatar

12.13.2011 , 07:13 AM | #1
To take advantage of the EGA, since I preordered in the first week, I downloaded the launch client installer, and I installed the client! It updated to version 4.0! It started downloaded the 18 Gb gamefiles, but every time, at different points, it gives the "error occurred updating"! Clicking repair won't do, as it restarts downloading the gamefliles from the first (for exemple, an error occurs on "main assets 17", click repair and it starts downloading again from "Main assets 1"), and then another error happens, and then repair, and then download from the start (I've done this for 8 times now)! The beta client of the 25 nov. worked fine, while the updates of the last beta test gave me the same errors, so I don't think my computer settings have anything to do with this! However I shut off the firewall and antivirus, installed all newest drivers and made a fresh install of the SWTOR launch client, but the problem persisted! I sent a ticket to the support, and upon their request I sent them the DxDiag and log, but they gave me no answer!
I made a quick research on google and it turns out I'm not the only one with the issue!
Now I'm frustrated, since I've been downloading again and again and again and nothing good came from it!

My computer runs on Win 7 64 bit
Intel core i5 CPU
ATI Radeon HD 5700 Series

Errors in log are like this:

20111213113721 ERROR File Error:Unknown file error in C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\Assets/swtor_main_anim_humanoid_bmaf_1.tor
20111213113721 ERROR File info: size=329904611, created=12/12/2011 7:13:40, accessed=11/5/2011 2:16:0, written=11/5/2011 2:16:0

and this:

20111213133223 ERROR Corrupt Source detected in C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\Assets/swtor_main_area_coruscant_1.tor (
20111213133223 ERROR File info: size=79239842, created=12/12/2011 7:14:31, accessed=11/5/2011 2:16:0, written=11/5/2011 2:16:0

Please help me! I really like this game, but this kind of problems overcome even the strongest affection!


the brave man posting on this thread have found an UNOFFICIAL solution:


In the first post of this page: There's an interesting hint to another much simpler workaround! Apparently the game doesn't like the "64bit/more than 3.5Gb of RAM" combination...

LexiCazam's Avatar

12.26.2011 , 05:55 AM | #2
Because the previous thread has exceeded our normal threshold for thread length, we've started this new thread.

As always, we ask that the community keep the following things on mind when responding:
  1. No insults, name calling, or personal attacks
  2. Please stay on topic.
  3. Please express your opinion and thoughts in a constructive, respectful manner.
  4. If someone violates the Rules of Conduct, please flag it instead of replying to it.

Thank you!

sabdizzle's Avatar

12.26.2011 , 07:05 AM | #3
Onto English asset patch 21 baby!

Honestly everytime i ran winmd5 and made sure all the files i had were valid it installed perfect without any problems. Except that freaking main asset 21 patch that thing took 5 tries but still... BrightCandles set up is the best way i've found to troubleshoot your way through this. Its long and a little tedious, but it gets the job done.

English asset patch 21 is not being friendly....

update: OMG 2nd time errored at 98%... Haha atleast that file is good gonna get this sucker soon.

BrightCandle's Avatar

12.26.2011 , 07:20 AM | #4
Definition of the problem:
When the game is downloading and installing via the launcher it will finish downloading the files and then offer you a repair link, which then starts downloading all the files again. After you've clicked this several times you realise its probably going to do this forever. The particular files people have problems with are Main Asset 1, En_US 1, Main Asset X and EN_US X where X is at least 21 but depends on BioWare's latest patch.

Known solutions:
I maintain a list of known solutions in the link in my signature. 95% of people can fix the problem using the manual download and the ram reduction workarounds. The SWTOR launcher is brilliant at spotting computer stability problems as well, better than any other program I've seen. If you have this problem and the workarounds do not work for you then follow the CS guide and run memtest and chkdsk at the very least, because stability makes up that 5% the other fixes don't help.
There used to be a repair for launcher problems here, but BioWare Customer Support has banned me from posting the link. My advice is if the launcher does not work is get a refund while you still can.

sabdizzle's Avatar

12.26.2011 , 07:36 AM | #5
Huuzzzaaaaaaaaaaaaaaahhhhh! 36 hours and its finally over! "I will bring the republic to their knees!"


Whew... Gonna go find some techn9ne to play...

samssf's Avatar

12.26.2011 , 09:43 AM | #6
Quote: Originally Posted by sabdizzle View Post
Huuzzzaaaaaaaaaaaaaaahhhhh! 36 hours and its finally over! "I will bring the republic to their knees!"


Whew... Gonna go find some techn9ne to play...
[Edit: document with fixes here.

Congrats! You've brought me hope. I hope the end of your suffering doesn't mean that Bioware will think the issue is resolved, though. I'm up after but a few hours of sleep, and let the client do its thing overnight. Of course, it had the same issue of downloading and installing corrupt files. Back to the manual method for me.

samssf's Avatar

12.26.2011 , 11:23 AM | #7
I got it, my first try (today) too!! Yeah baby!

These are the problems I had and what I did to get it to work:

Problem 1: Installer "downloads" / assembles corrupted compressed files (.z01, .z02, etc). This was solved by knowing the directory structure the installer uses, and downloading the files manually with wget, and verifying the MD5 checksum of each one, per BrightCandle's superb instructions and help. Spreadsheet linked in his signature.

Problem 2: Whenever the installer would actually unpack and install the .tor assets from the downloaded .z** files, it would fail while doing so. At the same time, it would delete all the downloaded .z** files, so we had to have those backed up, and replace them before clicking repair. This went on forever.

I don't know what caused problem 2, but here's what I did that eventually resolved it:

- Ran memcheck and verified ram was ok. Took out all RAM and put only 2GB in. Doubtful this did anything since problem persisted.
- Ran disk check in windows. Windows reported that it made changes to the file system.
- Searched for and installed the latest Intel Rapid Storage Driver, because I have a corsair C300 SSD. Also I use my hard drive / OS in AHCI mode. If you use AHCI, you might try updating your storage drivers.
- Even though I had 40GB free on my SSD, I deleted more files to free up 50GB.
- Ran disk performance testing tool. Everything checked out.

Deleted all the .tor files in /Assets, deleted the patchmanifest files in /patch, replaced all the downloaded archives, and re-ran the installer, and it worked.

Let me know how I can help...

mosephra's Avatar

12.26.2011 , 11:35 AM | #8
I was stuck at downloading english assets over and over again. I use avast anti virus and I set the launcher.exe to be ignored by the antivirus. This seemed to fix the problem after 1 night of painful forum research. Good luck and don't get too frustrated. See you guys online!

Zimerust's Avatar

12.26.2011 , 01:50 PM | #9
So basically there is STILL no fix. Thanks BioWare.

JordanHall's Avatar

12.26.2011 , 02:37 PM | #10
this is getting daft now
first time BW have let me down.

this issue isn't architecture specific is it?

Im running win7 pro 64bit and i haven't really sieved through the posts.

Anyone with a 32bit OS having the same issues with install patch ect.
To be fair.. we shouldn't have to try find our own fixes. which none have worked so far bearing in mind.

Can't BW just give us a fix and help those out who are suffering at their time of need XD
I can't wait to get things started.

annoying when you pay money for a game, that you cant play........................