Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Good bye guys


Pingonaut's Avatar


Pingonaut
02.05.2014 , 07:21 PM | #11
So you're leaving because you're trying to play on a toaster, even an outdated toaster?

RandomXChance's Avatar


RandomXChance
02.05.2014 , 07:39 PM | #12
Up until a few months ago I ran this on a 3.2 Ghz Dual Core (circa 2006) with 4 MB Ram and a Nvidia 285 (4 years old) with no problems in 16 man ops. Your computer is either way below the minimum, or some settings are bad. Something as simple as going from Fullscreen mode to Fullscreen(Windowed) can make huge differences in performance.

The engine is certainly not the best optimized, but considering the vast majority run it fine, the problem is most likely on your end in system or game configs.

Nickious's Avatar


Nickious
02.05.2014 , 08:04 PM | #13
Quote: Originally Posted by Nempo View Post
QFT

Stop trying to white knight for Bioware people. This engine is HORRIBLE.
It would help if the OP actually posted his computer specs before jumping to the conclusion its the engines fault.

I won't deny from reading other people's experience that swtor seems runs ****** on really high specced computers but I bet the majority of the time people complaining about problems playing this game are people are running this game with ****** specs.

Infernixx's Avatar


Infernixx
02.05.2014 , 08:05 PM | #14
Quote: Originally Posted by Nempo View Post
QFT

Stop trying to white knight for Bioware people. This engine is HORRIBLE.
The engine is fine. But, people should stop trying to play TOR on an Atari 2600. Or at the least, stop blaming TOR for their lack of a good computer.
Quote: Originally Posted by EricMusco View Post
Infernixx nailed it. This is correct.
Quote: Originally Posted by CosmicKat View Post
There is no excuse for any single use item to ever cost more than a month's subscription. Anyone who pays $10 or $20 for a single use item is hastening the death of TOR and feeding the rise of TOR:The Cash Shop Menace.

Icestar's Avatar


Icestar
02.05.2014 , 08:18 PM | #15
Quote: Originally Posted by Infernixx View Post
But, people should stop trying to play TOR on an Atari 2600
Hey, I got one of those. It was the first thing I ever played on

Perhaps I should try to hook it up with SWTOR and see what happens
"Though free to think and act, we are held together, like the stars in the firmament, with ties inseparable. These ties cannot, be seen, but, we can feel them"
- Nikola Tesla

Infernixx's Avatar


Infernixx
02.05.2014 , 08:33 PM | #16
Quote: Originally Posted by Icestar View Post
Hey, I got one of those. It was the first thing I ever played on

Perhaps I should try to hook it up with SWTOR and see what happens
I had one of those when they first came out, too. Over $120 dollars and that was back in the early 80s when that was a ton of money.

Good **** for its time.
Quote: Originally Posted by EricMusco View Post
Infernixx nailed it. This is correct.
Quote: Originally Posted by CosmicKat View Post
There is no excuse for any single use item to ever cost more than a month's subscription. Anyone who pays $10 or $20 for a single use item is hastening the death of TOR and feeding the rise of TOR:The Cash Shop Menace.

OddballEasyEight's Avatar


OddballEasyEight
02.06.2014 , 12:13 AM | #17
Yup... must be the engine... since I can run it just fine on my 6 year old machine that was a "medium" spec when I bought it...
It's an i5-2500 3,30Ghz w. 16Gb RAM using a GeForce GTX 550-Ti card...

Yup... must be the engine then... because everybody knows bad engines run best on old computers... or something


It can't possibly be that someone bought a monster computer and simply don't know how to set it up properly and maintain it properly with updated drivers for motherboards to graphicscards and normally just pushes through games with raw force.
And it can't possibly be that someone is using an old computer that sucks but can run WoW at highest settings and thus "should be able to run any MMO at highest settings".

Nope, couldn't be that, must be the engine.
Click here for free stuff.
Complaining about a problem without proposing a solution is called whining.
Click here to view my class storyline videos and preview blaster sounds

Dokar's Avatar


Dokar
02.06.2014 , 12:38 AM | #18
Quote: Originally Posted by OddballEasyEight View Post
Yup... must be the engine... since I can run it just fine on my 6 year old machine that was a "medium" spec when I bought it...
It's an i5-2500 3,30Ghz w. 16Gb RAM using a GeForce GTX 550-Ti card...

Yup... must be the engine then... because everybody knows bad engines run best on old computers... or something


It can't possibly be that someone bought a monster computer and simply don't know how to set it up properly and maintain it properly with updated drivers for motherboards to graphicscards and normally just pushes through games with raw force.
And it can't possibly be that someone is using an old computer that sucks but can run WoW at highest settings and thus "should be able to run any MMO at highest settings".

Nope, couldn't be that, must be the engine.
It is unlikely your computer is 6 years old since the i5-2500 was only launched in Q1/2011.

Aries_cz's Avatar


Aries_cz
02.06.2014 , 01:45 AM | #19
Quote: Originally Posted by Dokar View Post
It is unlikely your computer is 6 years old since the i5-2500 was only launched in Q1/2011.
Well, I DID play SWTOR on a computer that had 4 or 5 years old components when the game launched (bought and put together in 2007). AMD X2 3800+, GeForce 8800GTS, 4GB RAM. And I played with almost every setting on high (sans shadows, grass, character limit, and needless stuff like that). I still remember it running Crysis on Maximum details... every game ran perfectly until Witcher 2...
So, it seems that people are running it on something even older... and cannot wonder that they have crappy experience
Member of Beast Riders, Tomb of Freedon Nadd (EU-PvP)
Without the darkness, how would we recognize the light?
Aries, admin of Czech/Slovak fansite SW-TOR.cz
Check out my story videos

OddballEasyEight's Avatar


OddballEasyEight
02.06.2014 , 03:21 AM | #20
Quote: Originally Posted by Dokar View Post
It is unlikely your computer is 6 years old since the i5-2500 was only launched in Q1/2011.
Oh crap you are right hehehe... I forgot that I did buy a new computer 6 months after SW:TOR came out.
The one I had before that tho still ran the game just fine on highest (just without shadows).
Click here for free stuff.
Complaining about a problem without proposing a solution is called whining.
Click here to view my class storyline videos and preview blaster sounds