Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Incredibly slow download and install speed.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Incredibly slow download and install speed.
 

Wiitos's Avatar


Wiitos
09.24.2013 , 01:24 PM | #1
Hi,

I have recently re subscribed to the game and have encountered this problem on at least three occasions within the past two weeks.

The download speed and the installation speed is incredibly slow. A few times now I have been forced to leave my PC on over night and hope it finished by the next day.

I have tried everything I could do make it go faster. I have looked over every forum post on this site and others and any recommendation doe snot seem to work. I know I am not the only one with this problem.

Now, I am not a person to say that I will "quit" if this carries on, however I am a high school teacher and do not have a great amount of time to play as I once did. So when I do have free time and am unable to play then what is the point?

I am hoping more people are having this problem so that I know that it is not just me and that it can be fixed. Otherwise I may not keep up my subscription next month on the basis of me not being able to get my money's worth for my play time which is a shame as I really started to enjoy the game again and was really looking forward to starting operations.

Vairden's Avatar


Vairden
09.24.2013 , 06:36 PM | #2
I have to chime in on this topic as well. I've been a subscriber since launch, and I've NEVER had this type of problem until this month.

The last patch took 45 minutes and had me 15 minutes late for a progression level operation. I started today's patch early to avoid a repeat of being late. It has been "installing" for nearly an hour now, and it is only at 44.44% as I type this.

I will add that my machine is 1.5 months old, and without going into specifics, was professionally built for gaming. Not top end gaming, but gaming nonetheless. The machine is not the issue. I also have business class high speed internet in my home, so that should not be the issue either.

Any explanations or insight would be greatly appreciated.

Editing to say that I wasn't late to the Operation tonight after all. I simply missed it altogether... 3 hours since my initial post, and my "installing" bar has moved from 44.44% up to 53.73% in that time. I LOVE this game, but there is no excuse for this. From reading other posts, it seems this is mainly happening to those who downloaded the game from your site and have the streaming update active through "bit raider". At least that is the speculation. Some clarification on that would be nice.

I have no intention of threatening to quit, but you do have a very angry customer here, and the proper thing to do would be to respond with some answers.
If you argue that there are ANY lightly armored (non-adaptive) headgear options that don't look ridiculous, please explain why Satele Shan refuses to wear one.

Caldric's Avatar


Caldric
09.24.2013 , 06:43 PM | #3
What is crazy the patch notes state the following wouldn't just be a few megs at most?

9/24/2013

Launcher Update Patch Notes

Updates to Streaming Mode
•Selecting German in the launcher no longer causes all three languages to download. If you are currently using Streaming mode and playing in German, you can remove the following files from the “Assets” directory in your SWTOR install directory: swtor_fr-fr_*.tor and swtor_en-us_*.tor.
•Selecting French in the launcher no longer causes English and French to download. If you are currently using Streaming mode and playing in French, you can remove the following files from the “Assets” directory in your SWTOR install directory: swtor_en-us_*.tor.
•The in-game progress bar will now complete to 100% as intended and no longer requires a restart before players can travel off Origin Worlds.
•Account names beginning with a dash (“-“) can now launch the game as intended.
•BitRaider (Streaming) components no longer fail to stop after exiting the Launcher.

Updates to All Modes
•One Time Password page now displays properly in French.

CrispyWalrus's Avatar


CrispyWalrus
09.24.2013 , 07:05 PM | #4
Quote: Originally Posted by Caldric View Post
What is crazy the patch notes state the following wouldn't just be a few megs at most?
Very crazy... After reading all these posts I decided to get on the horn with CS and see if I could get a clear answer since it does seem from what I've read here that my game is reinstalling entirely. No such luck. BS was shoveled at me by the truckload. Just wait was the recurring theme along with.. no-- it's just the launcher updating... just wait... it will get faster after 50%... just wait.

I logged in today at 4PM EST only to discover SWTOR had ninja patched on me. Well It took like fifteen minutes for my launcher to update, which patch notes said was the only change. But after my launcher updated I reentered my password only to find that I am apparently installing the game again as after five hours now I am only at 42%. Something is up for sure as CS is not normally this busy either (took me 40 minutes to get through...).

None of the previous two months numbered patches have ever taken so long and those involved server down time. This supposed launcher update sure seems a lot thicker than launcher alone so I tend to believe the multiple posts stating my game is completely reinstalling. That in itself would be bad enough if only CS would admit it. That they continue to deny there is any problem rankles me even more...

Caldric's Avatar


Caldric
09.24.2013 , 07:08 PM | #5
I went 5% in an hour at that rate will be in the morning at 43% I am going to be angry if I redownload the entire game I only 120 a month and probably very close to that cap at the moment.

Shame_less's Avatar


Shame_less
09.24.2013 , 08:21 PM | #6
Mine has been downloading since 3pm and it is now 7:20pm and only at 57.73%... This is ridiculous, my computer is fast otherwise and my internet is fast. If this is just a launcher update it shouldn't take more than 5 to 10 minutes tops.

Soulles_Void's Avatar


Soulles_Void
09.24.2013 , 08:28 PM | #7
Quote: Originally Posted by Shame_less View Post
Mine has been downloading since 3pm and it is now 7:20pm and only at 57.73%... This is ridiculous, my computer is fast otherwise and my internet is fast. If this is just a launcher update it shouldn't take more than 5 to 10 minutes tops.
I got on the computer at about 11 this morning, NZ time, loaded the patcher on startup. It's now 2:30 in the afternoon and its only just got to 40.85%.
Yes, I realise I'm missing an "s" in my name. Drinking and account creation don't go too well together.

Casivek's Avatar


Casivek
09.24.2013 , 08:32 PM | #8
Quote: Originally Posted by Shame_less View Post
Mine has been downloading since 3pm and it is now 7:20pm and only at 57.73%... This is ridiculous, my computer is fast otherwise and my internet is fast. If this is just a launcher update it shouldn't take more than 5 to 10 minutes tops.
I agree, my computer has been "updating" since 4:00pm EST 9/24/2013 and at time of posting still updating and only at 52.76% at 10:26pm EST 9/24/2013. In this same amount of time I can uninstall then download and reinstall all of my games on steam which totals over 100Gb in half the time it has taken to do this "update." Honestly if I had not already payed for a subscription I would just uninstall this game and actually play a game; not sit here and watch one update for over six hours!

MatrixWarrior's Avatar


MatrixWarrior
09.24.2013 , 09:18 PM | #9
I'm having the exact same issue. I've been waiting and waiting for hours and I'm currently at 51.25%
This is crazy, I just started playing (and subscribed) about a month ago and I love the game. But if this is going to happen to me every time there's an update then I'm going to have to cancel this thing.

Critstix's Avatar


Critstix
09.24.2013 , 09:34 PM | #10
From all the reading i have been able to do in the time that i have been patching ( An hour and a half to get to 40%) it seems that the issue is the streaming downloader. The fixes listed in other parts of the forum suggest changing or deleting specific files or lines of code to "fix"the issue. Not something i am comfortable with especialy when the message pops up to warn us if we stop patching it will be necessary to redownload the game in its entirity ( which seems to be what it is doing anyway)

I would think that the correct course of action here is for the team to fix the issue and patch the fix into the game instead of expecting us to delete game folders or change lines of code that could easily cause us to have to redownload the game anyway if we screw it up.

Customers shouldnt have to use temporary bandages for issues that can cause hours of downtime from gaming. The issue should be addressed directly by the game developer to save any chance of a screw up on the customers end trying to work around the problem.