Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

FPS drops when in combat

MoogleNut's Avatar


MoogleNut
09.23.2013 , 12:35 PM | #1
Ever since Rise of The Hutt Cartel my fps has been dropping dramatically when in combat.
I get between 60 and 100 fps depending on the settings, but as soon as combat starts this drops to around 15, making the game increasingly painful to play.

I've been playing since launch and had no problems until Hutt Cartel - I though it might just be a problem on Makeb, but it is happening in every location.

I have tried everything from unparking my CPUs to memory cleaner, Radeon Pro to SWToR Unleashed - with no effect.
I have just tried a complete reinstall and still the problem occurs.

If anyone can shed any extra light on the problem it'd be much appreciated - I love this game but am increasingly unable to play because of this.

My DXDiag is as follows:

Spoiler

QuiDonJorn's Avatar


QuiDonJorn
09.23.2013 , 01:11 PM | #2
Yeah, ever since 2.3.3 the game's fps has been an issue again.
The game will run pretty well for the first few minutes after logging in but then i attack something and the fps drops to a slide show. Sometimes it will get better, but for the most part it is just frustrating to play.
I just redownloaded and reinstalled the game from scratch after uninstalling this past Thursday after running a flash point and deciding I had had enough. Well, I reinstalled the whole thing and nothing's changed. Frame rate is a major issue again.
Not to mention the game will no longer shut down for a few minutes, just black screen, so I have to bring up task manager to shut it down manually. Task manager says it's not responding.
Should I finally just move on? Just go back to modding KotOR 2? (uughh)
dxdiag:
Spoiler


I think most people would probably agree with me that this game just cannot run on a 2.1 gig machine with Windows XP 32-bit, an old 1 gig video card and a crappy dsl connection.
Yet I still try, 'cause I have not much else to do.

OwenBrooks's Avatar


OwenBrooks
09.24.2013 , 01:18 AM | #3
MoogleNut try the settings in this thread and see if they help - http://www.swtor.com/community/showt...=667864&page=2 also ensure windows power plan is set to "high performance" and the system isn't throttling due to heat.

QuiDonJorn try setting a profile for swtor.exe in the NVidia control panel and setting pre-rendered frames to 1 or 4 , this wont help with the actual FPS a lot but may help with stutter you appear to be getting

MoogleNut's Avatar


MoogleNut
09.24.2013 , 04:00 AM | #4
I've tried those setting Owen, thanks

It's still having no effect - I'm thinking it's a heat problem - my laptop does get very hot and the fps is red for cpu.
I've just ordered an external cooling mat (a Zelman with fan - they come highly recommended) to replace the gel one I've been using. Hopefully that will help. It will be here in a few days so will post an update once I've checked it out.

Thanks again for the tips

OwenBrooks's Avatar


OwenBrooks
09.24.2013 , 04:10 AM | #5
Thought I would post what my understanding of the colors mean

Quote: Originally Posted by Cerimon View Post
Greetings All,

So the actual explanation of the FPS display colors:

Red = Rendering bound/Video Card
Green = Simulation bound/CPU
Yellow = Mix of both
Current FPS (Lowest FPS over the last 10 seconds or so)

@nrazen_nl: some things just don't get into the patchnotes.

Thank you for playing Star Wars: The Old Republic