Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

attempting to buy cartel coins takes me to my ledger

STAR WARS: The Old Republic > English > Customer Service
attempting to buy cartel coins takes me to my ledger

Omnitheo's Avatar


Omnitheo
07.21.2013 , 11:43 PM | #1
When i click to purchase, my ledger opens. when I click the button to purchase coins, it takes me back to the store page. I'm just going in circles here for some reason

NicAX's Avatar


NicAX
07.22.2013 , 12:12 AM | #2
What internet browser are you using?

Try deleting all your cookies and site cache from "the beginning of time".

Also you could try using a different browser like Internet Explorer, Chrome, Firefox etc.

princedautomne's Avatar


princedautomne
07.23.2013 , 02:01 PM | #3
Same thing for me.. I guess i wont buy anything anymore.

edit: tried with Opera browser and seems to work. I am guessing a bug in firefox browser

Seerien's Avatar


Seerien
07.23.2013 , 02:23 PM | #4
I'm having the same issue using Chrome. I'll try a different one but I thought I'd mention it.

edit: worked in Firefox for me, yet didn't for the person above..... strange.