Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

SWTOR Launcher has stopped working

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
SWTOR Launcher has stopped working
 
First BioWare Post First BioWare Post

pavbernat's Avatar


pavbernat
06.25.2013 , 10:19 AM | #11
windows 7

bigmar's Avatar


bigmar
06.25.2013 , 10:20 AM | #12
Windows 7

Mjollnir's Avatar


Mjollnir
06.25.2013 , 10:20 AM | #13
Running Windows 7 64 bit

Tifo-Dias's Avatar


Tifo-Dias
06.25.2013 , 10:21 AM | #14
same thing here.. kinda relieved now haha

windows 7
"My luck ranges from barely tolerable to cataclysmic. I'm living proof that the force has a sense of humor."

Othea's Avatar


Othea
06.25.2013 , 10:21 AM | #15
Win 7

My Thread about same issue


Screen Shot of what it looks like

Are you at least sorry about the inconvenience?

Sileriak's Avatar


Sileriak
06.25.2013 , 10:21 AM | #16
Windows 7 here, the launcher still crashes in all XP compatibility modes

MagicAlien's Avatar


MagicAlien
06.25.2013 , 10:22 AM | #17
Have the same problem. OS is Win7.

Deleted all temporary files in client folder and forced client to re-download the files. But the error still occurs.

Poloz's Avatar


Poloz
06.25.2013 , 10:23 AM | #18
Win 7

Cerimon's Avatar


Cerimon
06.25.2013 , 10:25 AM | #19 Click here to go to the next staff post in this thread. Next  
Please go to www.swtor.com/download and download the latest launcher setup file. This will be used later.

Then, ensuring that you have the launcher closed and gone from your Processes list in Task Manager, delete the following files:
- "Patch" folder
- "Patcher_-1toXX" or similar folders
- "assets_swtor_XXX_XXX" or similar folders (do not delete the folder named "Assets")
- "Patcher.version" file
- "Launcher.settings" file
- "Launcher.exe" file

It's ok if not all these files are present, just delete the ones that are.

Then run the Fixlauncher.exe found in the client installation folder.

Once this has completed, please restart your computer in Safe Mode with Networking, and run the previously mentioned setup file.

Cerimon | BioWare Customer Service - Forum Support

GerberClimbs's Avatar


GerberClimbs
06.25.2013 , 10:26 AM | #20
I'm windows 8 but changing compatibility has not fixed the problem.