Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

[VIDEO] Ability Failure to Fire Bug

STAR WARS: The Old Republic > English > General Discussion > Bug Reports
[VIDEO] Ability Failure to Fire Bug

SOULCASTER's Avatar


SOULCASTER
04.19.2013 , 11:59 AM | #1
I really have been getting sick of this bug in game that i refer to as "ability failure", where you go to fire one of your abilities, and it simply does not fire, but uses the GCD (Global Cooldown).

To me this is a game-breaking bug. Especially in pvp where you may be 1v1ing, or trying to defend a node until help can arrive. You simply can NOT have ANY of your abilities failing to fire, and worse, locking you out for another 1.5 seconds while the GCD comes back around.

In this quick 2 minute video, i demonstrate what I'm talking about:
http://www.youtube.com/watch?v=u9l1G...ature=youtu.be

And here is a better example (1min video):
http://www.youtube.com/watch?v=iJmxr...ature=youtu.be

If you ask me, this should be a Priority 1 Bug-Fix. It literally hinders your game play in both PVE and PVP. This is also prevalent on all classes. And this happens on both instant abilities as well as casted and channeled abilities.

Thanks for watching.
Prophecy of the Five
Too many toons
7 Year SWG Vet (Bria)

LightForse's Avatar


LightForse
04.19.2013 , 12:13 PM | #2
Ty for taking the time to post this..hopefully something can be done about it soon..really getting old

breathofrockets's Avatar


breathofrockets
04.19.2013 , 12:18 PM | #3
Please fix this. It's so annoying, especially on classes like my watchman sentinel that chains a lot of abilities back to back.

Vasharto_Cain's Avatar


Vasharto_Cain
04.19.2013 , 12:24 PM | #4
Don't know if it's the same but i experienced this on my sage while pvp'ing.
But in my case i couldn't use anything for about 4-5 secs: every ability just used gcd while doing nothing.
I could move and jump but couldn't cast.
After a while it goes away and you can start re-casting.

Don't know if it's the same bug or not tbh or maybe my internet connection. But i'm pretty sure there weren't lag spikes.

MillionsKNives's Avatar


MillionsKNives
04.19.2013 , 12:47 PM | #5
Not to discredit your video, but I couldn't tell any misfiring. The way you were dancing around the screen it was hard to keep up with what your character was doing, let along seeing if one missed. Maybe when I get home I can take a better look to see it, but I feel that this issue could have been demonstrated better (assuming that this video does show abilities misfiring).

ghoul_drool's Avatar


ghoul_drool
04.19.2013 , 12:54 PM | #6
For me it's been happening on and off. I was fine for a coouple of days but while doing some casual levelling just now on the Harbinger my abilites just kept firing off belatedly or in some bad cases, not at all. I was doing anything major so it was more of an annoyance than anything else but I can certainly imagine situations where it's more than just annoying. Here's hoping they'll pick up on the problem soon!

Coltraine's Avatar


Coltraine
04.19.2013 , 01:10 PM | #7
Don't count on BW to ever fix this game breaking problem. You just need to live with it. There's this thread ability delay this will make or break swtor (something like that), it's been bumped to the first page regularly since January 2012, and for a while there before the massive layoffs they were actually making progress with this issue. However since 1.4 it's been as bad as ever.

It's a core problem with the heavily modified HERO engine and it won't go away unless you give it a major overhaul, and that will never happen.

SOULCASTER's Avatar


SOULCASTER
04.19.2013 , 01:13 PM | #8
Quote: Originally Posted by MillionsKNives View Post
Not to discredit your video, but I couldn't tell any misfiring. The way you were dancing around the screen it was hard to keep up with what your character was doing, let along seeing if one missed. Maybe when I get home I can take a better look to see it, but I feel that this issue could have been demonstrated better (assuming that this video does show abilities misfiring).
re-watch the last example i show then. Where I fire HIB, Stock strike and then Ion-Pulse...the ion-pulse fails to fire.
Prophecy of the Five
Too many toons
7 Year SWG Vet (Bria)

Deluxe_'s Avatar


Deluxe_
04.19.2013 , 01:18 PM | #9
It happens to me a lot when using Storm (Vanguard leap). I fire the ability and... nothing. GCD just keeps refreshing as I frantically try to activate other abilities (for some reason this is especially common during Huttball). But the funniest part is that, 4-5 seconds later, my Vanguard will finally leap onto the target, no matter how close or far from it. So now when this happens I try and play with it: it looks so crazy when you land a 40m leap, but it's just so funny when you leap on your target from 1-2m away.

Hamatula's Avatar


Hamatula
04.19.2013 , 01:22 PM | #10
signed, happens to me all the time...

seriously bw, look into this...