Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Space Mission Achievments not working correctly

STAR WARS: The Old Republic > English > Flashpoints, Operations, and Heroic Missions
Space Mission Achievments not working correctly

Dasbreen's Avatar

04.24.2013 , 10:02 PM | #21
I'm really sad that a lot of these aren't working. I'm also sad that there are none for the heroic space missions, though I doubt most of them would work anyways based on what does actually work. Please fix the things that the achievement system has basically highlighted as "Not working as intended"

BrokenHaiku's Avatar

05.02.2013 , 01:06 PM | #22
I have to wonder, who's in charge of Quality Assurance? Stevie Wonder?

Sykomyke's Avatar

05.10.2013 , 09:32 AM | #23
Bumping this as I believe if they are going to release an achievement system it needs to work. Also, a plethora of other achievements aren't working and we have yet to receive an acknowledgement of these bugged achievements or an ETA for a fix for them.
"I find your lack of faith disturbing."
Sith Empire

Voidwards's Avatar

05.15.2013 , 02:13 AM | #24
Still not working, did Ascendancy Barrier today, blew absolutely everything out of the sky, no banana.
Noxul - Marauder - Shades of Grey (Red Eclipse)

Leoness's Avatar

05.15.2013 , 03:36 AM | #25
EAware fails again.

Ansalem's Avatar

05.15.2013 , 03:57 AM | #26
apparently its too hard for BW to release a simple achievement system that actually works. I mean its really hard to check if the counter is working! I'm still miphed that they have done diddley and squat about the codex...same old bugged/missing entries and still not cleaned up...but hey at least we got yet another cartel market update...

PariahMessiah's Avatar

05.15.2013 , 10:13 AM | #27
They have other priorities like breaking the game for XP users and pushing out the cashgrabs as fast as possible.

soneil's Avatar

05.30.2013 , 12:13 PM | #28
Well now with the new patch it seems to have fixed most of these. There's only one annoying exception. The imperial mission sullust interception. There is one final objective I just can't get - decimate republic forces. I've done the command ship and destroyer turrets but I never even see the decimate republic forces one come up. On the equivalent republic mission, a bonus objective for destroying fighters appears as soon as you've destroyed enough fighters for the main objective. I assume that's the one that's missing here. It's the one objective stopping me from getting me the imperial aviator achievement. I've already got republic aviator.
Academy Exemplar - Gav Daragon
Republic 50s - Nefash, Tal-Hirron, Delin
Imperial 50s - Terrill, Rending, Vermeesa
Nefash's Pilot Training School - Space missions resource.

ThePrae's Avatar

05.30.2013 , 02:30 PM | #29
It's true I'm sitting at 98% of the imp acheivements and the decimate republic forces bounus from sullust intercept is the only thing I'm missing. This used to be a bonus that popped up but it doesn't anymore.

scottishhaig's Avatar

05.30.2013 , 03:42 PM | #30
Same issue for me with Sullust. All the other achievements are complete.