Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

SWTOR, Windows and Memory leaks - how to fix.

STAR WARS: The Old Republic > English > Server Forums > Dalborra
SWTOR, Windows and Memory leaks - how to fix.

Timbohh's Avatar

01.23.2013 , 06:51 PM | #21
Quote: Originally Posted by Tarrecq View Post
Hmm.. Still gets DC when finishing The Black Talon...
This program will fix the memory leak issue by manually performing a memory dump. It works, and works well. What it will NOT do is fix all of the multitude of bugs in the game.

Basically, will you still get the occasional game crash? Yes. Will it be from memory leaks/ram dumps? No.
Timboh, Timbohh, Idzol, Lozdi, Werthless
The Wins Legacy
"I'm a lover AND a fighter... simultaneously"

unexpectedemon's Avatar

01.23.2013 , 08:30 PM | #22
thanks...i will try it right now

DarthInsiria's Avatar

01.24.2013 , 06:26 PM | #23
Quote: Originally Posted by DarthInsiria View Post
Same here, will see how it turns out after maintenance.
Gonna post some feedback by the end of the day.
Ok meant to post feedback yesterday but gave it one more day of testing.
Unlucky for me it doesn't change a thing well except that every time I change location game lags for no reason.
Uninstalled. Still thanks for sharing some may find it useful.

darthnish's Avatar

01.25.2013 , 06:18 AM | #24
tested with swtor and someother games, works like a charm 10/10 will install again on other pcs.

Eterud's Avatar

01.27.2013 , 07:56 AM | #25
I tried using both memclean and cleanmem (ofcourse not at the same time)

Both make me unable to play the game,

Sure it loads quickly, but once I"m ingame swtor actually only takes up 71 mb of ram, and has 32000 ms.

I also used the bcdedit "fix" to enable more ram to be used under a 32 bit system.

Anyone knows how to fix this?

Sydexlic's Avatar

01.29.2013 , 11:02 AM | #26
This is dumb and does not work. See

All this application does is remove pageable memory from the applications working set. What is a working set? It's a collection of pageable memory that is currently located within the physical RAM of the system. This is good. If the process attempts to access a memory page that isn't in the working set, it results in a page fault. A page fault means the process must load the page from the backing store, ie, the page file. This is bad. Trimming the working set will cause more page faults and cause more swap file activity. Again, this is bad.

Don't fck with windows memory management, it knows better than you and it knows better than this app the best way to handle memory management.

With reference to memory leaks, it's probably there are some in swtor, there were many in WoW and they exist in many large applications. A simplistic tool like this isn't going to help with them, they are next to impossible to even reliably detect in optimised compiled executables and are usually only detectable with advanced (and usually expensive) code analysis tools at or before compile time.

Tarrecq's Avatar

01.30.2013 , 02:36 AM | #27
Well.. exept the Black Talon crash, it actually does keep me in the game all day, without any DCs

So thanks for fixing 50% of the problems I had with the game

deleries's Avatar

02.21.2013 , 12:16 PM | #28
Thanks for posting this..
I came back to the game yesterday after being gone since October. Game only lasted about 2-3 hours before it crashed. I played earlier today and went 1 hour before it started getting choppy and I had to log out. Two hours after logout I got a blue screen of death crash from memory errors!!
Just installed the memory cleaner hoping it works. Shame they haven't got this fixed yet. I have also seen this same issue since beta.

MystbladeWA's Avatar

02.22.2013 , 03:24 AM | #29
It only works for some people. Not me unfortunately. GL hope ur lucky enough.

Im upgrading to 64bit in a month and getting some new PC bits and pieces that i hope will alleviate my issues.
Hold'My'Beer Chill
I'Got'This Legacy

profhermit's Avatar

02.22.2013 , 09:41 PM | #30
Rock N Roll! I install this little applet, 4 hours as of this post & no crash.