Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Attack Of The Purple Crafted Item Bug

STAR WARS: The Old Republic > English > General Discussion
Attack Of The Purple Crafted Item Bug

Harryjames's Avatar


Harryjames
12.05.2012 , 09:50 AM | #1
I don't really like to complain, but I am going too this time. I spent hours and several thousand of credits gathering material to make a crafted purple item for a character. Finally after several attempts of reverse engineering I got the item, then gathered more material, spent more credits, and finally I was ready.

What a fool I was, I tried the item on, and was told, as a full subscriber, that I did not have subscriber permission to wear that item. I think I had an insane moment, like, throw the computer in the street moment. I see that there have been several other posts about this, but mum's the word from Bioware as to a fix. I think if I have to wait a week for this fix, I may consider unsubscribing, this is little much even for my tempered patience's.

TracyRay's Avatar


TracyRay
12.05.2012 , 10:07 AM | #2
Just got this same message on a piece i crafted.

Didnt happen on some implants but that was before this last patch or two, but def happened on my new earpiece.

Andryah's Avatar


Andryah
12.05.2012 , 10:13 AM | #3
Interesting.

I equipped 4 crafted artifact level implants yesterday (2 on character and 2 on a companion). I did not have any problems equipping them. Now I had them in storage for a while, so they were not newly crafted.

So it must be something more complex then just a purple crafted item.
I'm back..... in advance of KotFE.

chimex's Avatar


chimex
12.05.2012 , 10:37 AM | #4
The Progenitor (RP): Shazmi:<Crimson Moon>

FooBard's Avatar


FooBard
12.05.2012 , 12:19 PM | #5
I heard someone complaining about this last night. He crafted a purple implant.. and couldn't wear it. Got the restriction message... and he's a subscriber.

Fix it NOW BW. lol....

BlaadG's Avatar


BlaadG
12.05.2012 , 03:01 PM | #6
Having same bug.

Paid game time still running, subscription permissions stop me from equipping crafted implants on alt.

lumuni's Avatar


lumuni
12.05.2012 , 03:04 PM | #7
Girlfriend had this bug too and has pretty much quit the character that was inhibited by the bug now. Limitations on f2p should NEVER have a chance to bleed to subscribers.

HelinCarnate's Avatar


HelinCarnate
12.05.2012 , 03:45 PM | #8
Hey so thats what broke on the last patch.
Dear BW,
Please nerf paper and buff rock. Scissors is fine as is.
Signed, Rock.
http://www.swtor.com/r/mB5FPn obligatory referral link.

uaintjak's Avatar


uaintjak
12.05.2012 , 03:58 PM | #9
Quote: Originally Posted by HelinCarnate View Post
Hey so thats what broke on the last patch.
Well that and your companions no longer unify colors.

Midget_Yoda's Avatar


Midget_Yoda
12.05.2012 , 04:09 PM | #10
Quote: Originally Posted by Andryah View Post
Interesting.

I equipped 4 crafted artifact level implants yesterday (2 on character and 2 on a companion). I did not have any problems equipping them. Now I had them in storage for a while, so they were not newly crafted.

So it must be something more complex then just a purple crafted item.
So... you were unable to reproduce the bug under different conditions. Wow, thanks for that incredibly useful input.

White Knight -1