Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Unable to retrieve server list.

STAR WARS: The Old Republic > English > Customer Service
Unable to retrieve server list.
First BioWare Post First BioWare Post

DarthGuiGan's Avatar


DarthGuiGan
11.23.2012 , 01:13 PM | #1
I was running fine this morning, but now after lunch can't play.

I am able to login. I have no problem with the patcher. I'm on the latest patch, 1.5.0a, 11/16. My internet connection is fine and has been reset just in case.

I get Unable to retrieve Server List. Server Error Code 4001. The "more info" link leads you to a help page that says "Updating...".

I need help or I'm going to have to unleash the Rakghoul plague on everyone.

Tirvaak's Avatar


Tirvaak
11.23.2012 , 01:19 PM | #2 Click here to go to the next staff post in this thread. Next  
Please DarthGuiGan,

Do not release the plague again, we had enough trouble with that the last time .

I'm sorry to hear about the issue you are having logging into the game. I'd like to confirm when exactly do you get this error? Does it appear on the launcher or at the server select screen? Any extra details you have would be very helpul.

Thanks.

Tirvaak | Bioware Customer Service - Forum Support

DarthGuiGan's Avatar


DarthGuiGan
11.23.2012 , 01:26 PM | #3
Quote: Originally Posted by Tirvaak View Post
Please DarthGuiGan,

Do not release the plague again, we had enough trouble with that the last time .

I'm sorry to hear about the issue you are having logging into the game. I'd like to confirm when exactly do you get this error? Does it appear on the launcher or at the server select screen? Any extra details you have would be very helpul.

Thanks.
Yes, at the Server Select Screen. The problem began this aftrnoon. I was working fine this morning. I installed 36 Windows updates. Prior to installing the updates the problem did not occur. I'll generate a list of updates and post to this thread.

Tirvaak's Avatar


Tirvaak
11.23.2012 , 01:32 PM | #4 Click here to go to the next staff post in this thread. Next  
Hi DarthGuiGan,

It's ok, you don't need to list each update the details you have given are fine. so there are a few thing s we can try to see if we can get you back in. Generally the error is related to a problem along the connection, more often that not due to the firewall or security software on the system.

If one of these were updated today it could be a possible cause. First I'd like to rule out possible corruption in the asset files, so could you run the repair through the launcher to see if it makes any difference?

Open the launcher again and login as normal but do not press play. When the play button appears click on the cogwheel in the left corner of the launcher and select repair.

Let me know if this helps..

Tirvaak | Bioware Customer Service - Forum Support

DarthGuiGan's Avatar


DarthGuiGan
11.23.2012 , 01:42 PM | #5
KB2756822
KB2505189
KB2727528
KB2729453
KB905866
KB2533623
KB2468871
KB2737019
KB2563277
KB2687311
KB2736233
KB2749655
KB2761226
nVidia - Graphics Adapter WDDM1.1, Graphics Adapter WDDM1.2, Other hardware - NVDIA GeForce GTX 260
KB2545698
KB2596660
KB2729449
KB979099
KB2754670
KB2661254
KB982480
KB2596848
KB2687307
KB890830
KB2522422
KB2679255
KB2687315
KB2492386
KB2705219
KB2533523
KB2600217
KB2724197
KB2698023
KB2687440
KB2761451
KB2687314

This is a Vista system, SP 2.

DarthGuiGan's Avatar


DarthGuiGan
11.23.2012 , 01:45 PM | #6
Repair scan is in progress. I don't run a firewall, I've had too many problems with them in the past. I just simply don't use Twitter, Facebook, or any of the other sites that are most likely to provide me a virus. And I don't open any E-Mail unless I know who it has come from.

DarthGuiGan's Avatar


DarthGuiGan
11.23.2012 , 01:47 PM | #7
File scan completed successfully.

KeldStarwind's Avatar


KeldStarwind
11.23.2012 , 01:52 PM | #8
I was also suffering this issue today, with the added complication that sometimes, the server list appeared completely blank. The last Windows 7 update I did was about 2 weeks ago, and the game had been running fine since then. Also, everything was working last night when I was playing (logged out around Midnight Pacific Time).

The repair feature on the Launcher worked and restored the game for me.

Lastly, before the fix, sometimes when I tried opening the Launcher this morning, I got a 'Unable to connect to the patcher message', preventing me from even logging in.

Hope this helps in the analysis

Tirvaak's Avatar


Tirvaak
11.23.2012 , 02:16 PM | #9 Click here to go to the next staff post in this thread. Next  
Thanks for the info KeldStarwind,

@DarthGuiGan: After completing the repair are you able to login or do you still encounter the error message?

Thanks.

Tirvaak | Bioware Customer Service - Forum Support

DarthGuiGan's Avatar


DarthGuiGan
11.23.2012 , 02:19 PM | #10
No change. I'm still getting the same error message.