Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher Freezing

First BioWare Post First BioWare Post

StrawHatLuffy-'s Avatar

11.19.2012 , 07:13 AM | #1
Hi, before free to play i tried to download the star wars the old republic client and the launcher froze during Installing Main Assests 1 87%.. figured ok, maybe its the server. After free to play i tried to download the client again. Same thing happened but this time at 45%, and again 2 more times at random %'s.

The downloading speed disappears and the % doesnt move (had it downloading all night)

Is there anyway i can download the game a different way from the launcher? Or how can i keep my launcher from freezing?

No its not my internet connection.

StrawHatLuffy-'s Avatar

11.19.2012 , 10:34 AM | #2
Seriously no one?

StrawHatLuffy-'s Avatar

11.20.2012 , 08:09 AM | #3
Bump... love how no one answers the question especially customer service reps, very cool... makes me totally want to play the game

Cerimon's Avatar

11.20.2012 , 08:34 AM | #4 This is the last staff post in this thread.  
Greetings StrawHatLuffy-,

There are some things to go through to resolve this issue.
  • Try to use a Ethernet cable to connect rather than connecting wirelessly if possible.
  • Make sure your Firewall has added to its exceptions.
  • Remove and re-add an exception for SWTOR.exe and launcher.exe to your Firewall and Anti-Virus.
  • Open up TCP ports 80, 8995 and 12000-12999. For more information on this see here:
  • Do a Cold Reboot of your router.
  • You may also need to flush your dns.
  • Avoid using any port blocking or script blocking software.
  • Make sure to have an updated and cleanly running version of Internet Explorer on your PC regardless of whether you use this browser or not.
Please let us know if you have a continuing issue.

We apologize for any inconvenience caused and thank you for playing Star Wars: The Old Republic

Cerimon | BioWare Customer Service - Forum Support

Ryaja's Avatar

03.24.2013 , 08:19 AM | #5
I am having the same exact problem. I have played before. Trying to come back to the game after about a year gone. I have tried everything your above post says...I have done every troubleshooting guide on the forums. I am currently on hold with customer support after the initial rep said I needed to spec with a "higher tech". I have been on hold for an hour and 16 minutes. I even completely uninstalled the game and currently tried to download game in safe mode. It downloads English Video 1 and then during installation of english video 1 it freezes at random points.....41% 39% 15% even 81%. HELP!!!!!! I am at my wits end with this!!!!!!

OwenBrooks's Avatar

03.24.2013 , 08:27 AM | #6
Give the directions in this link a try, ensure your using the setup from

Ryaja's Avatar

03.24.2013 , 08:49 AM | #7
Yep already did all that. Even redownloaded from the link you put on there... English Video 1 is now stuck at intalling 3%! This is ridiculous

OwenBrooks's Avatar

03.25.2013 , 01:26 AM | #8
Try deleting any patch folders and try again if this fails you may need to run memtest 86+

Ryaja's Avatar

03.25.2013 , 08:05 AM | #9
After running a CHKDSK, I was able to get passed english I am stuck doing the same thing on Main assets 109...Everytime I download it, it starts to install and goes to 2% then down to 1% and reads repair (5)....suggesting I run a repair tool. This loops over and over on main assets 109....I then deleted the file assets_swtor_main.version and I am starting over downloading main assets 1...hopefully this works but not counting on it...The good thing is I have 30 Mbps download speed and downloading at 3.80 MB/s so it is going quick.

Ryaja's Avatar

03.26.2013 , 12:41 AM | #10
Update...I have now downloaded main assets 109 when it goes to install the update it gets to 23% everytime and then pauses then immediately crashes. It said something to the effect of SWTOR Launcher has quit responding and windows is looking for a solution. Please help................