Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Low FPS - Poor Performance

First BioWare Post First BioWare Post

Kyuuu's Avatar


Kyuuu
07.21.2012 , 11:47 AM | #21
Its the games engine that is problems Bioware knows this and so does most the population at this point. Weather BW is gona admit this or not is another question. I know for damn fact the compression ratio used in this game is terrible. Loading times are terrible, When SSD has same almost identical load times and same issues as HDD then the game engine problems become painfully obvious. No nvidia driver will fix the game engines problem either. Special when I went from 45sec boot time on HDD to 9 sec boot time with the SSD and everything else i have installed on sdd is damn near instant loading now. and the whole Ramdisk fix/ workaround is not something anyone should have to do.

Nvidia claimed they optimized there drivers for this game months ago, But there is actual no optimizes done, every driver from 304.78 all the way back to 275.33 have identical performance. The optimizing needs to be done to the engine code to fix the poor loading times and terrible performance a 500$ video card gets.

Game has only been out for about 8 months one can only hope BW fixes the the atrocious loading times some people have and terrible FPS 500$ video cards have that 100$ video card would have in same situations as the more expensive one.

The only people that say there is no problem are the people that cant see the huge fps drops, or walk away when there game is loading. or just simply kissing bw ***.

billyconnite's Avatar


billyconnite
07.21.2012 , 05:40 PM | #22


Bump

WTB BioWare post.
Kramer // Cake is Real // Giddy Up

Rikeryo's Avatar


Rikeryo
07.21.2012 , 07:32 PM | #23
Quote: Originally Posted by billyconnite View Post


Bump

WTB BioWare post.
I really doubt we'll ever see bioware admitting those engine problems, let alone releasing a fix. I've been around this board since launch and I've read nearly every thread about performance issues. believe me, there used to be a lot of them - with ten thousands of posts - before the mass exodus of players of course. but bioware didn't even once reply. obviously the majority of the remaining people gave up because bioware did everything to destroy their customer's faith.
5% club member

billyconnite's Avatar


billyconnite
07.21.2012 , 11:17 PM | #24
Quote: Originally Posted by Rikeryo View Post
I really doubt we'll ever see bioware admitting those engine problems, let alone releasing a fix. I've been around this board since launch and I've read nearly every thread about performance issues. believe me, there used to be a lot of them - with ten thousands of posts - before the mass exodus of players of course. but bioware didn't even once reply. obviously the majority of the remaining people gave up because bioware did everything to destroy their customer's faith.
Absolutely.

The first step to fixing a problem is acknowledging it's there.

I'll be bumping this post every day until I either quit playing this failing game, or until a BioWare employee acknowledges their game engine is not efficient enough to utilize modern (And older) hardware - Even hardware that was available whilst production began. Doing more testing last night showed that while my graphics card is on adaptive power mode, I can still achieve the exact same frame rates as on full performance mode (Static clocks and voltages) - However on adaptive power mode the graphics card will lower memory and clock frequencies during the times I receive lower fps - GPU Usage will also go down, while ALL other hardware remains performing fine, with no bottle-necking - As stated in my initial post. This is because the card is simply not being utilized and the game engine is bottle-necking and STOPPING rendering while processing some data - Most likely character data coming from the servers.

This is something other MMO's class as HIGH priority, it's an MMO, you're going to have hundreds of characters around; This is why you thread your applications properly, you need multi-tasking and seamless loading of character models and their movement, and abilities, whilst other rendering is still being processed, not ceasing altogether because a programmer can't separate tasks properly that can be run side-by-side. This would explain while in high populated areas/areas with many things going on (WZ's, OPS) we will receive this pathetic performance.

Poor programming. Too much content, pushed too quickly = Bad optimization.

Bump.
Kramer // Cake is Real // Giddy Up

Ganan's Avatar


Ganan
07.22.2012 , 05:16 AM | #25
It's not anything on your end software or hardware wise, system bellow your specs should run the game smoothly on max setting regardless of what area you are in or how many players are nearby.
anyone who starts throwing around insanely high specs or the famous compatibility setting tweaks to "fix" the problem clearly as no idea what hes talking about.

I followed this game since 2008, through beta, and launch, I quit a month or 2 after launch and came back recently to check if this problem was fixed... it has not... back when the first screens came out there were tons of feedback, mostly about the huge sized saber hilts lol, but also about the "cartoony graphics" I and many other MMO players though the graphics were pretty good even if cartoony, they would allow for a smoothe and stable system, boy were we wrong.
what sadens me is that even tho not a perfect MMO (missing vital community and exploration mechanics and content), it is imo by far the best MMO that has been launched in the last 4-6 years... and I would gladly play it under subscription, if I could enjoy all of it in its best quality, I wonder how many subs like mine were lost because of this problem? how could a MMO creator make such a dreadfull graphic engine that suffers precisely on the key situations of MMO gaming, medium-large (even small somewhat) groups.


is there actually any hope of the engine being fixed? there are AWESOME posts in the community describing what's wrong... the bottlenecks, the graphic engine stop rendering when loading assets, the general missuse of system resources etc... if after this long its not fixed, will it ever be? /shrug

its really inexcusable that I run SUPERIOR graphic setting on OLD MMO's some of them like AoC having superior graphic quality aswell, on max settings with hundres of players in action with high FPS while this game I am forced to play on insanely low graphic settings and still get lagged.
"There is no greater slavery, than falsely believing you are free"

billyconnite's Avatar


billyconnite
07.22.2012 , 08:03 AM | #26
Hi Ganan,

Yes it's quite pathetic that BW jumped into an engine that provided them nothing but fast production over efficiency for managing even as few as 16 characters within the same area (WZ's).

How they thought they would get away with this with in an MMO is quite interesting.

What I find troubling, is given we hear nothing from BW about performance and optimization - This most likely means they acknowledge the current state of the engine is pathetic, but will do nothing about it at this point because they lack the time and man power, remaining silent about big issues such as this usually means nothing will be happening for some time, if ever - They need to prioritize development of whatever they feel will bring them in as much financially as possible before they provide this game F2P - Given the game will go down in history as the fastest dieing MMO based on initial subscribers from 2 million to 0 in 12 months. Perhaps they feel pushing out content to keep the current persevering subscribers subscribing is priority over providing a high-quality game that can grow over the coming years.

The community having no voice and BW not listening will be the end of this game.

--------------------

bump.

Looking for a BW post.
Kramer // Cake is Real // Giddy Up

billyconnite's Avatar


billyconnite
07.23.2012 , 09:07 AM | #27
bump.
Kramer // Cake is Real // Giddy Up

Cerimon's Avatar


Cerimon
07.23.2012 , 09:34 AM | #28 Click here to go to the next staff post in this thread. Next  
Greetings billyconnite,

Firstly, my apologies for the delay in responding to you.

Please try the following steps to improve game performance:
  • You should make sure that you have the correct DirectX components installed on your system. For further details please check here
  • You should check that you have the latest Service Pack and Windows Updates installed for your operating system including the optional updates such as .NET Framework and Visual C++ features.
  • Please uninstall Java and download and install the latest version.
  • Ensure Internet Explorer is up-to-date regardless of whether you use it as a browser or not.
  • Uninstall video driver, clean boot and then clean driver install.

    Depending on the graphics card the uninstall can differ:

    I will leave instructions for both vendors for the benefit of other readers.

    NVidia recommend completing this through Control Panel/add/remove programs.
    1) Go into your Control Panel
    2) Double-click the Add/Remove Programs icon
    3) Select the NVIDIA Windows Display Drivers from the list of programs.
    4) Click Change/Remove or Add/Remove button.
    5) Confirm with Windows that you wish to continue with the uninstall

    Nvidia link:http://www.nvidia.com/object/IO_13955.html

    ATI on the other hand recommend removing drivers via their own catalyst:
    1) Click on Start
    2) Open the Control Panel
    3) Select Programs and Features
    4) Select ATI Catalyst Install Manager
    5) Click on Change

    AMD link:http://support.amd.com/us/kbarticles...csDrivers.aspx

    Instructions on performing a clean boot: http://support.microsoft.com/kb/929135

    When installing an Nvidia driver please choose the advanced install and tick the box for "perform a clean installation".
    When installing AMD drivers, just perform the installation as normal after the clean boot.

Please post again to let us know if this increases your game performance.

Thank you for playing Star Wars: The Old Republic

Cerimon | BioWare Customer Service - Forum Support

billyconnite's Avatar


billyconnite
07.23.2012 , 10:35 PM | #29
Quote: Originally Posted by Cerimon View Post
Greetings billyconnite,

Firstly, my apologies for the delay in responding to you.
All good.

Done and done (Already everything up-to-date, but I did it anyway).

Exact same issues.

bump.
Kramer // Cake is Real // Giddy Up

Cerimon's Avatar


Cerimon
07.24.2012 , 07:28 AM | #30 Click here to go to the next staff post in this thread. Next  
Greetings billyconnite,

At this point we would like to take a closer look at your system. Please look in your game installation folder for a file called launcherDiag. If this file is present please run it and then email the resultant .tgz file to support@swtor.com detailing the problem and troubleshooting steps already completed.

If the launcherDiag file is not present please send an email as above but with your Dxdiag, MsInfo and most recent Launcher log attached. Please see the following post for information on how to obtain the Launcher log and Dxdiag: http://www.swtor.com/community/showthread.php?t=83908

To get your MSINFO:
  1. Press Windows Key + R
  2. Enter into the following window “MSINFO32” and press ENTER
  3. Now you have the “System Information” open
  4. Click on “File” -> “Export” and save the file at any location convenient (default: Desktop) All this information must be saved as .txt file.

With the detailed information in these files we will be in a much better position to diagnose any player side issues and will advise accordingly.

Thank you for playing Star Wars: The Old Republic

Cerimon | BioWare Customer Service - Forum Support