Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Low FPS - Poor Performance

First BioWare Post First BioWare Post

TheLordMagnus's Avatar


TheLordMagnus
04.29.2013 , 04:19 AM | #161
Quote: Originally Posted by OwenBrooks View Post
If what you experirnce is like a stutter , in your case lowering pre-rendered frames to 2 or 1 will likely stop the stutter, but also try setting to 4 and see what works best for you.
the guy has a 4.2ghz cpu and a gtx titian thats a 1000$ video card and you tell him to lower performance to get the 10 to 20 fps crap to stop have a look at his specs before posting useless information

his system should run the game 100fps with 50 people on the screen while in combat no problems

the game engine needs the boot other games have done it this one needs to do it as well
LVL 50 SORCC RDPS ACTIVE
LVL 30 JUG DMG ACTIVE
LvL 50 MARRA ACTIVE

Rousso's Avatar


Rousso
04.29.2013 , 05:29 AM | #162
The performance in this game has never been great, and in some cases not even acceptable.

I refuse to fork out money to upgrade my system when it's way above the "recommended" specs set by the creators of the game itself, which means I'm subject to about 5 - 20 FPS in Warzones for ever. While the game is "playable" at best, the graphic / input lag can sometimes severely affect my performance not to mention cause needless frustration.

Essentially, this budget engine was chosen by an ill-informed moron who was looking to please his shareholder overlords by saying "look we can make a game on this tin can engine that's not even finished and it'll cost us next to nothing". Even now, the engine costs $99/year (http://www.heroengine.com) and IIRC Elder Scrolls: Online have dropped it too.

Now that Bioware are addressing the majority of the minor issues with this game I suspect we're going to see more and more complaints about the performance. I REALLY hope there's some major stuff going on behind the scenes to phase out this old, broken engine (yes, I know this is a MASSIVE task and not very likely as it's the foundations of the game) or at least get some proper optimization in. Unless these things are addressed, I don't realistically see a flourishing future for this game. I also wonder just how much they'd like to do with this game that they can't because the engine can't handle it.

EDIT - Just wanted to add, that this is one of the weirdest games I've ever played in regards to settings. I set everything to "Very high" and I'm averaging 11 FPS, set everything to "Very low" and I'm averaging 17 FPS... what the hell is that about?? The settings are obviously working, because "Very low" makes the game look horrendous - even by 2001 standards.

OwenBrooks's Avatar


OwenBrooks
04.29.2013 , 06:11 AM | #163
I'm not sure why you guys keep playing to be honest and my gtx670 is performing better then his titans so maybe he needs to tweak as not sure why he isn't blowing my card out of the water (SLI or driver issue ?) , his fps is dropping to 16fps and setting to 4 will help with that regardless.

I do not have a FPS issue with this game @ 2048 x 1152 , yes there is a few areas that drop me to about 40 but that is it

I have done what this guy did http://www.swtor.com/community/showthread.php?t=631727 limited my frame rate to 60 to keep temps down
my dxdiag
Spoiler

Rousso's Avatar


Rousso
04.29.2013 , 07:35 AM | #164
Quote: Originally Posted by OwenBrooks View Post
I'm not sure why you guys keep playing to be honest and my gtx670 is performing better then his titans so maybe he needs to tweak as not sure why he isn't blowing my card out of the water (SLI or driver issue ?) , his fps is dropping to 16fps and setting to 4 will help with that regardless.
We're playing because we want to play. The game is worth playing, it's a pretty huge achievement and there's currently no better MMO out there at the moment. What people are complaining about is the terrible performance a LOT of people are experiencing. I think what everyone (affected) is really waiting for, is some acknowledgement from BioWare that there's an issue that's affecting a lot of people who can't / won't shell out an extra 500+ to upgrade their stuff WAY past initial stated requirements.

The REAL issue in my eyes here isn't so much that the engine is massively under performing, it's that no matter what people do to tweak their setup doesn't work. This is the first game I've ever encountered where, for example, turning shadows OFF has no discernible affect on the current FPS. There's an entire section the game no longer has to process there i.e. shadows - and we get what, a 3 - 4 FPS improvement??? That's just plain wrong.

OwenBrooks's Avatar


OwenBrooks
04.29.2013 , 07:52 AM | #165
Rousso

Your statement about shadows is odd , turning on and off is about a 20fps difference for me, actually posted this recently

here is the thread where I tanked my FPS as much as I could and turning shadows boosted the FPS back up
http://www.swtor.com/community/showthread.php?t=631147

Have a read of Taankjr last post as well in that thread, and his 2nd last post has a link that people say they have had some gains.

Rousso's Avatar


Rousso
04.29.2013 , 08:21 AM | #166
Quote: Originally Posted by OwenBrooks View Post
... here is the thread where I tanked my FPS as much as I could and turning shadows boosted the FPS back up
http://www.swtor.com/community/showthread.php?t=631147 ...
Thanks for this, the off-shoot thread http://www.swtor.com/community/showthread.php?t=591313 actually looks very helpful. I'm at work at the moment, but will give this a try as soon as I get home and post back.

Lilouk's Avatar


Lilouk
04.29.2013 , 08:53 AM | #167
I just lowered my resolution gaining me quite a boost on FPS. I'm not totally happy with it, i mean i run BF3 on ultra in 1920x1080 getting around 60FPS in multiplayer!

My PC should be able to run SWTOR in max settings without a problem but it doesn't. The engine will bring even the most powerful PC to it's knees and that right there, tells you how bad it is.

I only noticed a drop in FPS from 2.0 onwards, so for now i've had to lower the resolution as a temporary fix(Maybe permanent if BW don't fix it).

What would be helpful is people stop saying 'upgrade your pc', most the people who have experienced these issues have a System more than capable of running this game.

ItsToof's Avatar


ItsToof
04.29.2013 , 09:32 AM | #168
This game has been out almost a year and a half and this is still an issue?

I thought my inactivity for a year would have given sufficient time for them to sort this out, boy was I wrong.
My specs:
Low spec, bro

Fiesbert's Avatar


Fiesbert
04.29.2013 , 09:39 AM | #169
Quote: Originally Posted by Rousso View Post
Thanks for this, the off-shoot thread http://www.swtor.com/community/showthread.php?t=591313 actually looks very helpful. I'm at work at the moment, but will give this a try as soon as I get home and post back.
Wow this did help somewhat. The game runs smoother and the interface lag is gone. This guy is definetly onto something!
I noticed that my CPU speed changes a lot while playing SWTOR. Does one of you tech guys know if this is a problem? I got an i7 950 and I am aware that it is able to adjust its voltage and clock itself up and down.

Rousso's Avatar


Rousso
04.30.2013 , 03:44 AM | #170
Quote: Originally Posted by Rousso View Post
Thanks for this, the off-shoot thread http://www.swtor.com/community/showthread.php?t=591313 actually looks very helpful. I'm at work at the moment, but will give this a try as soon as I get home and post back.
This actually did work. I'd suggest people try this, although it's geared towards a 670/680 I used the same settings on my 560ti and got at least a 15 FPS increase.