Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Mögliche Ursache von niedrigen FPS

First BioWare Post First BioWare Post

nhyc's Avatar


nhyc
07.03.2012 , 03:38 PM | #11
meiner ansicht nach liegt das ruckeln an einer datei im assets- ordner. ich kann jetzt nicht genau sagen wie sie heisst weil mein pc tot ist (R.I.P) und ich deswegen vom lappy schreibe. die besagte datei ist nur 166mb gross, wird aber ständig benutzt, benennt man diese testweise um, hat man zwar die meisten kampfsounds, laserschwerter, animationen, mounts usw nicht mehr aber man kann in wz´s absolut flüssig spielen.

das ist für mich, nach mehrmonatigem swtor-studium die logischste erklärung aller erklärungen die ich bisher gelesen habe. deswegen ist es meist auch scheissegal welche garfikeinstellungen man verwendet, die datei wird immer gleichschnell ausgelesen, und zwar verhältnissmässig saulangsam, da sie auf der fp gespeichert ist und nahezu alle kampftechnisch wichtigen effekte alleine in dieser 166mb grossen datei enthalten sind.

programmiertechnisch ein einziger riesengrosser FAIL, und nein ich bin KEIN computerprofi aber logisch denken kann ich trotzdem

Raxputin's Avatar


Raxputin
07.03.2012 , 05:29 PM | #12
falls betriebssystem und spiel auf der selben SDD installiert sind - würde ich das spiel mal auf eine nicht SSD festplatte auslagern.
hat schon bei 2 leuten geholfen - die sonst auch schon alles probiert hatten.
liegt am controller der SSD

Zwiebelbauer's Avatar


Zwiebelbauer
07.04.2012 , 08:48 AM | #13
Quote: Originally Posted by nhyc View Post
meiner ansicht nach liegt das ruckeln an einer datei im assets- ordner. ich kann jetzt nicht genau sagen wie sie heisst weil mein pc tot ist (R.I.P) und ich deswegen vom lappy schreibe. die besagte datei ist nur 166mb gross, wird aber ständig benutzt, benennt man diese testweise um, hat man zwar die meisten kampfsounds, laserschwerter, animationen, mounts usw nicht mehr aber man kann in wz´s absolut flüssig spielen.

das ist für mich, nach mehrmonatigem swtor-studium die logischste erklärung aller erklärungen die ich bisher gelesen habe. deswegen ist es meist auch scheissegal welche garfikeinstellungen man verwendet, die datei wird immer gleichschnell ausgelesen, und zwar verhältnissmässig saulangsam, da sie auf der fp gespeichert ist und nahezu alle kampftechnisch wichtigen effekte alleine in dieser 166mb grossen datei enthalten sind.

programmiertechnisch ein einziger riesengrosser FAIL, und nein ich bin KEIN computerprofi aber logisch denken kann ich trotzdem
Schonma Danke an alle fleißigen Helfer

Hab grad eben diese Datei unbenannt und hatte im pvp meistens um die 40 Frames. Also wesentlich besser. Allerdings ist das ja kein Zustand so spielen zu müssen und das werd ich au ned machen ohne Sound und grafikeffekten.

Bei Festplatten sind "normale" also keine SSD. auf einer ist Windows mit treibern und sonstigen Programmen. auf der Größeren nur Spiele und eigene Datein. Die Spiele Platte ist glaub ich sogar Sata III allerdings auf Sata II angeschlossen, was nach meiner Erfahrung nicht soooo viel ausmacht. Ist deswegen auf Sata II, da über Sata III nicht erkannt wurde bzw. waren die Anschlüsse denk ich im Bios deaktiviert.

Falles es an der auslesegeschwindigkeit liegt wie kann ich die denn erhöhen? Ramdisk hab ich auch schonmal getestet ohne Erfolg... Vll hab ich auchs nur falsch gemacht hat da jmd noch ein guten Guide?

MFG

Zwiebelbauer's Avatar


Zwiebelbauer
07.04.2012 , 09:28 AM | #14
So hab das mit Ramdisk nochmal versucht und bin nach dem Guide vorgegangen

http://www.swtor.com/de/community/sh...d.php?t=143506

Hab den manuellen Weg genommen ohne diese Skripte und auch die 166MB datei mit rübergeschoben. Brauchte keine Verbesserung.
Bei der RamDisk erstellung über das Programm konnte man noch 3 sachen auswählen: Image file, Image file in RAM und Empty Ram drive. Ich hab mch für Emty Ram drive entschieden und 4 GB hergenommen.

Wäre es auch möglich das mein RAM zu langsam ist? Im CPU-Z steht eine DRAM Frequenzy von 669,7 und eine NB Frequenzy von 2008,9. Ich kenn mich da leider ned so aus, wäre schön wenn jmd schreiben kann ob das passt.

Sonst noch jmd ne Ahnung woran es noch liegen kann? Ich bin immer noch der Meinung das Swtor meine Grafikkarte iwie ausbremst oder meine Graka das Spiel nicht immer als Spiel sieht und deswegen nur so 30% mitmacht. Die Frame Anzeige ist wie gesagt auch immer Rot.

MFG

Zwiebelbauer's Avatar


Zwiebelbauer
07.07.2012 , 01:19 AM | #15
Hat keiner mehr was, was ich sonst noch ausprobieren kann?

nhyc's Avatar


nhyc
07.07.2012 , 05:46 PM | #16
also ich hab mir jetzt nen neuen rechner bestellt und den typ der mir den zusammenbaut gefragt wie er das problem mit besagter datei lösen würde. er meinte man könne diese irgendwie direkt in den vram der graka verschieben, hats mir auch erklärt aber ich bin eindeutig zu noobig um das bewerkstelligen zu können. auserdem weissich nicht ob er nur wichteln wolllte oder ob das wirklich geht, googeln kannst ja mal danach

ich geb auf jeden fall mal rückmeldung wies mit dem neuen system am mi oder do mit ssd dann läuft. sollte es dann immer noch ruckeln wars das definitiv mit swtor. nen 2. rechner schrotte ich fix net ;D

Zwiebelbauer's Avatar


Zwiebelbauer
07.10.2012 , 01:00 PM | #17
Quote: Originally Posted by nhyc View Post
also ich hab mir jetzt nen neuen rechner bestellt und den typ der mir den zusammenbaut gefragt wie er das problem mit besagter datei lösen würde. er meinte man könne diese irgendwie direkt in den vram der graka verschieben, hats mir auch erklärt aber ich bin eindeutig zu noobig um das bewerkstelligen zu können. auserdem weissich nicht ob er nur wichteln wolllte oder ob das wirklich geht, googeln kannst ja mal danach

ich geb auf jeden fall mal rückmeldung wies mit dem neuen system am mi oder do mit ssd dann läuft. sollte es dann immer noch ruckeln wars das definitiv mit swtor. nen 2. rechner schrotte ich fix net ;D
Hab mal danach gegooglet aber ned wirklich was gefunden. Muss auch sagen dass mir sowas dann ein wenig zu weit geht^^ da hab ich mehr angst das ich noh mehr kaputt mach als ich reparier.
Es ist halt wirklich extrem komisch.... Hab mir vor paar tagen sone Testversion von einem Tune Up tool geladen (hab den Namen vergessen) und des mal komplett durchlaufen lassen und die Verbesserungsvorschlägebefolgt usw. Aber das brachte au keine besserung. Habs dann direkt wieder deinstalliert.
Hab auch im Inetrent bisschen gekuckt und auch festgestellt das die geschwindigkeit von meinem 1333Mhz RAM mit 669,7 Frequenz normal. Hab mir mal HDD speed test geladen um meine Festplatte auf der SWTOR Installiert ist zu untersuchen. Leider kann ich mir den Zahlen ned viel Anfangen.

Eingestellt war das tool auf 20 Datein mit 10MB größe und die Systemcache war deaktiviert.
- Schreibzeit = 2,1761 Sekunden ; 4,5953770 MByte/s
- Lesezeit = 0,2426 Sek ; 41,2201154 MByte/s

Keine Ahnung ob das jetzt passt.... Aufjedenfall schneidet sie besser ab als meine älter Festplatte mit Windows.

Falls jmd noch was hat, einfach hier rein schreiben

Zwiebelbauer's Avatar


Zwiebelbauer
07.13.2012 , 09:03 AM | #18
Mag sich vll ein Droide nochmal melden?
Finds bisschen schade wenn ein Mitarbeiter einen Lösungsansatz gibt aber den Thread dann nicht weiter beachten

Mundako's Avatar


Mundako
07.14.2012 , 03:36 AM | #19 Click here to go to the next staff post in this thread. Next  
Quote: Originally Posted by Zwiebelbauer
Mag sich vll ein Droide nochmal melden?
Finds bisschen schade wenn ein Mitarbeiter einen Lösungsansatz gibt aber den Thread dann nicht weiter beachten
Hallo Zwiebelbauer,

es tut mir leid, falls es den Eindruck bei dir hinterlassen hat, als ob wir deinen Thread nicht weiter beachten. Ich kann dir versichern, dass dem nicht so ist, allerdings ist es für uns sehr schwer bei FPS Problemen weitere Hilfestellung zu geben, da wir keinerlei Tools verlinken können oder Eingriffe in Treiber- oder Windowseinstellung vorschlagen können. Bitte entschuldige, falls ich deinen Thread eventuell auch falsch aufgefasst habe. Für mich sah es zunächst eher nach einer Art "Ideensammlung" zur Steigerung der FPS aus, als nach einem eigentlichen "Hilfethread". Daher hatte ich auch nur den Hinweis zur Einblendung der FPS Anzeige gegeben und mich dann auf die Community verlassen, die ja auch hier im Thread sowie in einem anderen Thread wertvolle Tips geben konnte: FPS Probleme mit neuem System

Hier allerdings noch einmal ein paar Dinge, die durchaus zu Verbesserungen führen könnten:
  • Aktualisiere beziehungsweise installiere deinen Grafikkartentreiber neu
  • Defragmentiere deine Festplatten
  • Trenne Auslagerungsdatei und Spiel auf mehrere physikalische Festplatten auf (falls vorhanden)
  • Lösche die Datei DiscCacheArena aus dem Installationsordner (Cachedatei, die beim Spielstart neu angelegt wird, falls nicht vorhanden)

Eventuell kann ja einer dieser Tips ebenfalls zu einer Steigerung der allgemeinen FPS führen. Ebenfalls möchte ich mich bei der Community für die zahlreichen Antworten bedanken.
Mundako | Bioware Customer Service - Forum Support

Elte's Avatar


Elte
07.14.2012 , 09:29 AM | #20
[QUOTE=Mundako;4850440]Hallo Zwiebelbauer,

es tut mir leid, falls es den Eindruck bei dir hinterlassen hat, als ob wir deinen Thread nicht weiter beachten. Ich kann dir versichern, dass dem nicht so ist, allerdings ist es für uns sehr schwer bei FPS Problemen weitere Hilfestellung zu geben, da wir keinerlei Tools verlinken können oder Eingriffe in Treiber- oder Windowseinstellung vorschlagen können. Bitte entschuldige, falls ich deinen Thread eventuell auch falsch aufgefasst habe. Für mich sah es zunächst eher nach einer Art "Ideensammlung" zur Steigerung der FPS aus, als nach einem eigentlichen "Hilfethread". Daher hatte ich auch nur den Hinweis zur Einblendung der FPS Anzeige gegeben und mich dann auf die Community verlassen, die ja auch hier im Thread sowie in einem anderen Thread wertvolle Tips geben konnte: FPS Probleme mit neuem System
[/QUOTE

Wieso könnt ihr bei FPS problemen nicht helfen?
Es scheint ja am Spiel zu liegen.Kenne mich nicht aus mit den Dingern aber da wurde wohl ein großer fehler begangen.Tut mir leid wenn ich das sage aber bei,wow war das Problem nie da.(zumindest wo ich gespielt habe)
Konnte es 3 mal starten und es lief flüssig.Ok Tor Grafik ist besser,aber sonst?
Ich wette drauf das es nur ein kleines programm ist was diese probleme auslöst.

Und dazu die Frage,das Spiel wurde doch getestet mit all möglichen zusammgebauten Rechnern,es wurden wohl doch nur die besten teile genommen und nicht auf die verwendeten Hardware der jetzigen gamer geachtet,wodurch ihr jetzt quasi ahnungslos seit.Haben die in Amerika diese probleme nicht?
Die Sith machen uns alle Blind