Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Camera view messing up

First BioWare Post First BioWare Post

Sabreblood's Avatar


Sabreblood
05.17.2012 , 10:10 AM | #1
I have this problem when i am playing my Sniper. In wz i use my left mouse button to look around me. Most of the time when i am running and looking around with the left mouse button pressed and then release the camera will go back to normal view ( front view), but after a view times do so it changes to when i release the left mouse button my sniper will turn in the direction i was viewing, This only happens when i play my sniper, no other toons. I have checked my mouse and camera settings. Still does not fix the problem. When this happens if i log on to another toon i continues to that toon too.

I have to shut down the game and computer. Restart to get it to go away.

Any help would this problem would be appreciated.

Beesodd's Avatar


Beesodd
05.17.2012 , 10:53 AM | #2 Click here to go to the next staff post in this thread. Next  
Hi Sabreblood,

Thank you for reporting this bug, I have experienced it myself at times. If it happens again, please report it using the in-game tool(/bug), including as much detail as possible about where your character was and what they were doing when the issue started. The more information we have, the easier we can track down the source of this issue.

Thanks again.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

MsCats's Avatar


MsCats
07.24.2013 , 07:34 PM | #3
This is a problem I have been having with most, if not all, of my alts no matter what zone I am in. I am moving along and all of a sudden I find myself moving in another direction, or looking up at the sky. It's cost me my life a few times, as I've run off platforms on Makeb, or run into mobs. I was directed to check this board for possible answers, but I haven't been successful.

Jenix's Avatar


Jenix
07.25.2013 , 02:10 AM | #4
I am having this same issue all the time everywhere in this game. it just started happening just a few weeks ago, so it is a recent issue that has propped up. Its a real pain in the behind. There is no real way to describe this issue from what other posters have already posted on this issue, as it happens randomly but at a constant rate everywhere in the game. It seems to happen when a single click with either mouse buttons, right or left, is clicked behind the character. this happens with either the character moving or even standing still. the camera seems out of control, and I have the camera rotation set to "0". I have tried numerous different types of mouse's, but has not resolved the issue. IT IS NOT A MOUSE ISSUE. It has something to do with the camera rotation, I feel like the speed or the adjustment of the camera default rotation has changed some how in game.

Skirge's Avatar


Skirge
07.25.2013 , 08:24 AM | #5
This started happening to me aswell , most of the time it happens in wz when holding one of the mouse buttons down and running. The character just randomly starts running in any direction except the one that i want to go or the camera view just turn straight up to the ceiling. It has happend in pve aswell but less accuring than in wzs.

Jenix's Avatar


Jenix
07.26.2013 , 11:52 AM | #6
Update:

I thought I would post a work around that I have been using to get rid of about 95% of the camera rotation issues that I have been having until bioware can come up with a fix. The in game settings for the camera rotation says "0" but its actually a weird number slightly over (".1")

I went to the account .ini file and changed the value of the camera rotation speed from .100000149 to .05. As long as you don't change any in game settings for the camera, this value will stay locked in game. you can also make the change to your liking, it does not have to be .05. I started with .08 but made the change to .05 because it worked for me much better.

This change is a godsend until a fix comes around.

MsCats's Avatar


MsCats
07.28.2013 , 07:42 PM | #7
Where is that .ini file located?

Jenix's Avatar


Jenix
07.29.2013 , 02:45 PM | #8
Sorry I did not get back to you sooner. Here is the path to the main account .ini file.


This .INI file is located in ( C:\Users\%USER%\AppData\Local\SWTOR\swtor\settings \%ACCOUNTNAME%_Account.ini )

Hope this helps.
P.S. In order for you to see the app data folder, you may have to show hidden folders, you can go to control panel and find the folder options, and I believe its under the view tab, click the radio button that allows you to show hidden folders.

Woofii's Avatar


Woofii
07.30.2013 , 01:49 AM | #9
Yeah this happens to me too and is super frustrating and only really happens on my sniper and entering cover or rolling is when it normally happens.