Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

SWTOR won't install properly

First BioWare Post First BioWare Post

xRaynx's Avatar

04.10.2012 , 05:12 AM | #1
Hi. I've been trying to reinstall SWTOR ever since I started getting some really bag lag issues one day that made the game unplayable. I ran a virus scan and cleaned my pc a little to see if that would fix it, but it didn't. So I reisntalled the game, and when it apparently had installed correctly, I opened up the launcher menu. The launcher menu wasn't working right. when I tried typing in my account info, the menu turned black and kind of looked empty but it still let me type in my info and log in. After that, I let the game take however long to patch itself but during the patching i got an error that said it was unable to retrieve patch data. After that when I tried to start up the game, it crashed. After I tried again, I noticed I didn't have any repair options when I opened up the repair menu, the repair menu was just blank aside from being able to chose a language. Now knowing what to do, I downloaded the client and tried installing it this way. The install seemed unusually quick, but it still apparently installed SWTOR into the right folder. Now, when I started the launcher menu this time, I didn't seem to have any of the problems I had before, and I let it patch itself. After a certain amount of time though, the patch freezes to the point where it says the program has stopped responding.

I've been playing TOR for months now and I haven't had these kinds of issues before and it's really really aggravating. Can anyone help me?

Beesodd's Avatar

04.10.2012 , 05:34 AM | #2 This is the last staff post in this thread.  
Greetings Rayn,

Please check to see if you have a "patch" folder in your main game folder. If you do, please delete that and try to repair again. If that does not help, please rename the launcher to launcherabc and run the fixlauncher.exe that can be found in the game folder.

If the issue is still persisting, please post up a copy of your latest launcher log, within spoiler tags.

You can find your launcher logs at one of these default locations:

- For 32 bit Operating Systems - C:\Program Files\Electronic Arts\BioWare\Star Wars - The Old Republic\logs
- For 64 bit Operating Systems - C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\logs

Launcher logs look like this: “launcher_112610.txt”

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Sylvest's Avatar

01.27.2013 , 02:36 AM | #3
I have been having a problem lately. I am trying to install SWTOR but after it download Main Asset 1 og start to install. I reaches 54% and then it just freeses. I have been trying EVERYTHING! Runned fix launcher, updating Java and microsoft, following your website advice, but none has worked. PLease Help

OwenBrooks's Avatar

01.27.2013 , 02:42 AM | #4
Try the below steps, - "Patcher_-1toXX" or similar folders are usually the issue in most cases for it to continue not to patch correctly.

Quote: Originally Posted by Bronholz View Post
Greetings kenandk,

Thanks for contacting us, please follow the steps below to try and resolve the issue.

Please go to, download the latest launcher setup file and run the setup over the current installation. After this please remove and re-add firewall and antivirus exceptions for SWTOR.exe and Launcher.exe.

Then, ensuring that you have the launcher closed and gone from your Processes list in Task Manager, delete the following files:
- "Patch" folder
- "Patcher_-1toXX" or similar folders
- "assets_swtor_XXX_XXX" or similar folders (do not delete the folder named "Assets")
- "Patcher.version" file
- "Launcher.settings" file
- "Launcher.exe" file

Then run the Fixlauncher.exe found in the client installation folder.

Once this has completed, please restart your computer in Safe Mode with Networking, and let it patch.

Thanks for your patience.