Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Minimum Graphics Card: 256MB 1GB not enough....

STAR WARS: The Old Republic > English > Customer Service
Minimum Graphics Card: 256MB 1GB not enough....

Reapon's Avatar


Reapon
12.16.2011 , 03:56 PM | #1
So why is the minimum graphics card a 256MB of RAM card, but people can't get over 12 FPS with 1GB card? Was there a problem that never got fixed on the minimum requirements page? I for one will not be registering my copy, and instead will return it to the store as it is completely unplayable at the time being without a 2+GB card from what I have been seeing and reading.

Keytea's Avatar


Keytea
12.16.2011 , 04:07 PM | #2
I am running it fine with sapphire radeon x1950 pro 256 mb... on medium details(1920x1080) just fine.. turn off shadow(and the other options) and then check your fps.. play with your graphich settins till you are happy with them graphic/fps wise

Reapon's Avatar


Reapon
12.16.2011 , 04:18 PM | #3
All of my settings are on low and shadows are off....I have tried every fix i have found on the forum and cant seem to get above 20 FPS even when standing still against a wall.....apparently there are alot of people experiencing the same problems as me, including people with top of the line computers.

Keytea's Avatar


Keytea
12.16.2011 , 04:23 PM | #4
I suppose you did the standart "fix" procedure of getting newest(working) drivers?

some people claim that they get higher fps when forcing AA(doubt it) of setting details to high.

iain_b's Avatar


iain_b
12.16.2011 , 04:26 PM | #5
Quote: Originally Posted by Reapon View Post
So why is the minimum graphics card a 256MB of RAM card, but people can't get over 12 FPS with 1GB card? Was there a problem that never got fixed on the minimum requirements page? I for one will not be registering my copy, and instead will return it to the store as it is completely unplayable at the time being without a 2+GB card from what I have been seeing and reading.
Video memory is only part of the picture.

BTW, my 1GB 6870s play the game just fine at 100fps with high settings at 1920x1200.
My Little Pwny
Kulok Dunar, Powertech and GM of MLP. Want to join? Click here for info.

Squadron 1020 & 367

iain_b's Avatar


iain_b
12.16.2011 , 04:27 PM | #6
Quote: Originally Posted by Reapon View Post
All of my settings are on low and shadows are off....I have tried every fix i have found on the forum and cant seem to get above 20 FPS even when standing still against a wall.....apparently there are alot of people experiencing the same problems as me, including people with top of the line computers.
Have you put all your settings on high?

Then disabled Bloom and shadows?
My Little Pwny
Kulok Dunar, Powertech and GM of MLP. Want to join? Click here for info.

Squadron 1020 & 367

Reapon's Avatar


Reapon
12.16.2011 , 04:28 PM | #7
A list of things i have tried:

updating drivers
uninstalling drivers then reinstalling
complete reinstall of the game
shadows off (not low)
turn graphics to high then shadows off
windowed mode
using my CCC to force AA off
using CCC to force AA to max
vertical sync off
vertical sync on
fullscreen(windowed) mode
looking at the ground/wall to check for FPS drops
standing off by myself
settings completely to lowest possible through the client
settings completely to lowest possible through CCC

possibly other things that I can't think of at the moment.

As I said, this seems to be a problem that many people are having.
Alot of people played fine on high in the beta, and the same computer can't play on low in the live release. Seems as though something was messed up in the final build, but the company doesn't seem to want to take responsibility.

overlordmike's Avatar


overlordmike
12.16.2011 , 04:29 PM | #8
my card, a nvidia geforce gts 250 2gb version gets about 40fps when standing still, high teens when movements going on.

i have run mmos such as rift, wow, and dcuo in pvp and in raids on max settings with no lag. something is wrong
i can feel the anger dwelling within

Reapon's Avatar


Reapon
12.16.2011 , 04:30 PM | #9
Quote: Originally Posted by iain_b View Post
Video memory is only part of the picture.

BTW, my 1GB 6870s play the game just fine at 100fps with high settings at 1920x1200.
I am playing on 1280x1024 with low settings and getting a top end max of 25 FPS on my 1GB.

overlordmike's Avatar


overlordmike
12.16.2011 , 04:30 PM | #10
i was getting about 60-80 fps during beta, so im with ya there
i can feel the anger dwelling within