Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Horrid FPS


trueanimus's Avatar


trueanimus
05.02.2012 , 08:28 AM | #681
Quote: Originally Posted by DiGzY View Post
After trying most fixes for Fps issue, i tried one last thing , running Swtor in windows xp service pack 2 compatibility mode. While i would not go as far to say that the issue is now fixed, the game is now playable.
The list of settings and fixes i followed are to long to list and after spending a large part of my spare time since 1.2 was released on the problem, i just want to get back to enjoying what still is a great game.
It is worth noting that i believe it was a combination of advice/fixes that i tried and not just switching to a compatibility mode.
Gl

AMD Fx 6100 six Core Processor
8Gb Ram
Windows 7 64bit
AMD Radeon HD 6770
This is one thing that you should have tried from the start like the rest of us. Running in XP compt mode is the only thing that has made the game even slightly playable for most of us that are having fps issues and with that rig you shouldnt be having any problems at all.


The fact still remains, even though this thread has slowed down to a crawl, the game is almost dead already, and the only reason most people are still here is for the free month. After the 20th of this month the servers will become a ghost town because they refuse to fix anything.
Formerly Known as Trueevil of Tarquinas server SWG or Truelydead/trueid/truelock/truedewd/truecan/truelyinsane/truelynsane/trueblu/truebacca of undermine in WoW

SuspectDown's Avatar


SuspectDown
05.02.2012 , 09:04 AM | #682
Quote: Originally Posted by nightwise View Post
FPS is STILL terrible.

i have a i5 2500k and 2 x gfx 570 and i get 30-45 fps in wz's making them annoying as hell to play since everytihng is choppy and laggish, and i'm running with v-sync so that makes it even worse.
(everything under monitors refresh rate makes it feels sluggish)

Tried a clean install of win 7 64bit = changes nothing.
Tried disable sli / change driver settings = changes nothing

Gfx cards are sitting at 40-45% usage max. if i lower setting ingame usage goes down in the 20's
the i5 quardcore is sitting at around 40% aswell.

I believe this is the 13th version of the horrid fps thread, so something is clearly wrong here.

I've tried to be patient and wait it out but its been around 5 months now and nothing have changed since launch pretty much, its unaccepable and i've unsubbed.
The reason anything under monitor refresh rate feels slow when VSYNC is on is because it is NOT displaying what your FPS counter says. For PVP you should turn VYSNC OFF.

The reason being with VSYNC on...

@ 60 FPS you're seeing 60 FPS
@ 30-59 FPS you're seeing 30 FPS
@ 20-29 FPS you're seeing 20 FPS
@ 15-19 FPS you're seeing 15 FPS

VSYNC does NOT display actual FPS once below 60. With VSYNC on, it will always be 60, 30, 20, 15, or lower.

As for the drop in performance, have you tried disabling SLI and seeing what your FPS is like? That could actually help and it's worth a shot at least.

DiGzY's Avatar


DiGzY
05.02.2012 , 09:18 AM | #683
Quote: Originally Posted by trueanimus View Post
This is one thing that you should have tried from the start like the rest of us. Running in XP compt mode is the only thing that has made the game even slightly playable for most of us that are having fps issues and with that rig you shouldnt be having any problems at all.


The fact still remains, even though this thread has slowed down to a crawl, the game is almost dead already, and the only reason most people are still here is for the free month. After the 20th of this month the servers will become a ghost town because they refuse to fix anything.
Think most would have tried xp service pack 3 and not thought to have tried service pack 2 but you probably just like making pointless posts dont you, go back to your cave, game is not dead.

redheadedtim's Avatar


redheadedtim
05.02.2012 , 09:36 AM | #684
I actually had better luck running as not xp compatible. More stable than it was prior to doing that. I think it's clear there are no silver bullets that work for everybody.

Apocsig's Avatar


Apocsig
05.02.2012 , 12:51 PM | #685
wow this has been going on for months....



I think i found a reason why this is happening
http://www.google.com.au/imgres?q=bi...-haze-in-Milky

Mightynandui's Avatar


Mightynandui
05.02.2012 , 05:00 PM | #686
How can this still be happening so many months after the release?!? I have already quited the game a month ago because there is no answer from bioware.

I thought bioware was better than this. If they can't even fix their engine, the game is not gonna survive. And yes, yes, I know that after this post there will be a lot of ppl that owns Nasa computers that will say they run the game perfectly fine. If you are happy to lie or playing with less than 15 fps with good hardware, congrats to you all.

It's a shame the game is being treated like this.....soon it will be another mediocre mmo.

To all you that still play the game with all this problems don't stop fighting for a answer and a solution. Good Luck!

SuspectDown's Avatar


SuspectDown
05.02.2012 , 06:42 PM | #687
Quote: Originally Posted by Mightynandui View Post
I thought bioware was better than this. If they can't even fix their engine, the game is not gonna survive. And yes, yes, I know that after this post there will be a lot of ppl that owns Nasa computers that will say they run the game perfectly fine. If you are happy to lie or playing with less than 15 fps with good hardware, congrats to you all.
Well, my posts with proof showed it wasn't a lie...

Are there problems? Absolutely, the game isn't even 6 months old. However, to say EVERYONE has problems is BS.

Ritsi's Avatar


Ritsi
05.03.2012 , 03:28 AM | #688
Well mate I agree with you that as it is a "young" MMO, it is expected to have problems. However, imo it is unacceptable at 2012 not to be able to fix such things by the end of the first 3 months. Yes, I know WoW was far worse when it came out, but that was bk in 2004!!!!

My point is that BW and EA, apparently knew about the problems. They just forced a Christmas launch, whether out of arrogance to make more money, or out of inability to continue production because of budget running out.

I may be wrong but can't help thinking this is the case...
Pls fix the FPS issues with this game already....

skidrows's Avatar


skidrows
05.03.2012 , 03:47 AM | #689
If you have a problem with shudder or so and OC try remove the OC and run CPU, GPU at default that can help, one 4890 i know you even had to underclock it with 1% to get it to be stable.

Nothing over clocked have original motherboard drivers for NB and so, have ATI 10.7 or some were around that with is stable and 99% of the time everything runs just fine for me, have the built-in soundcard disabled and run a Asus Xonar DX card, have a P8Z68-M Pro and i5-2500k (ok it is oc but its Intel/m-boards oc nothing forced).

_Flin_'s Avatar


_Flin_
05.03.2012 , 06:10 AM | #690
Quote: Originally Posted by Mightynandui View Post
How can this still be happening so many months after the release?!? I have already quited the game a month ago because there is no answer from bioware.
Interesting to see that this thread is still alive and the FPS are still horrid. I struggled for months with this. Now I just dont play anymore and guess what: No more fps problems.