Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Horrid FPS


Beatrups's Avatar


Beatrups
03.10.2012 , 04:42 AM | #101
The areas i have low FPS rates: Fleet, Warzones, Closed areas such as caves. I've hit a average of 25 FPS, which is unplayable, especially when it drops from 110 FPS all of a sudden.

The trend in low FPS rates for me is when there are a large number of players/npcs in the same area.

Also when i'm running along or rotating my character from left to right whilst opening various windows such as character screen etc, my FPS will drop to nothing at all, like 1-2 FPS.

http://www.youtube.com/watch?v=KEuFZbdJsKk - Opening windows whilst moving causing low FPS.

Click the spoiler for system details.

Spoiler

Birubi's Avatar


Birubi
03.10.2012 , 04:57 AM | #102
Yep i also been having fps issues in wazones to the point where Alderaan is becoming unplayable ie 10 fps or less since last patch & this morning seem to be getting crazy lag spikes too

Have a Nvidia Geforce 8800 GT card & have updated the driver to 295.73 which has actually made it slightly worse
The Only Sith in the Village

eldelphia's Avatar


eldelphia
03.10.2012 , 06:08 AM | #103
What's frustrating me, is that until this week, I could run Warzones no problem. My hardware setup isn't worse or different...

So I have a Valor rank 42ish character which whilst not uber is an indication of how much PVP I was doing in warzones... another at 20ish and now I can barely function. I don't understand why. PVP warzones are some of the things I enjoy the most and I can barely function now. Whereas I was zooming around Alderaan etc with no issues. What's changed?

Nothing else has changed. I don't have an uber system but I do have AMD Athlon II x4 (2.8GHZ), 8 GB of ram. My card isn't fantastic so a friend is selling me one cheap but it's above the minimum spec and more to the point ran this game fine until recently. In fact I've turned my settings DOWN this week in the hope of improving things and it's just not.

I downloaded the new drivers for my card, released yesterday and the application profiles. It's made a tiny difference. So frustrating.

I'm now having issues inside where I wasn't before /sigh
Mexi [Sage] ~ Ari'th [Scoundrel] ~ Eldy [Commando]
Formerly ICE Breaker now Corellian Run - Drunken Jedi Masters

Macce's Avatar


Macce
03.10.2012 , 06:49 AM | #104
Quote: Originally Posted by dlaselle View Post
I personally think the issues lies within the people computer.
I agree with you, when i played Beta and after the game came out i was frustruated witht he lag/ Low FPS. PvP was hard to play as my skills and everything seemed to be 5 seconds after everyone else!

After this i upgraded my old computer with New Ram, CPU and Motherboard(Cause old one did not support my new CPU and DDR3 Ram).

And now i can play PvP even with no lag, haven't checked my FPS for a long time but dont need that anymore its all smooth and working fine!

Game is not bugged, its their computers.

I mainly think it was my CPU that fixed the FPS problem as i used a software with my old computer. Think it was 'Game Booster' and it fixed the problem but my computers fan ran at full power :P

So people who have low FPS try Game Booster if you dont want to Upgrade your computer!

Birubi's Avatar


Birubi
03.10.2012 , 07:43 AM | #105
Yeah i know my set up isnt the greatest far from it but what i dont understand is that before the patch the game ran fine in warzones the only issue i had was a little stuttering on the fleet at peak times.
Also some guildies are reporting similar issues & their pc set ups are alot better
The Only Sith in the Village

SWTORgameing's Avatar


SWTORgameing
03.10.2012 , 10:11 AM | #106
I tryed game booster didn't make a single diffearence... remember, I can play games like BF 3 crysis on high settings but not this!

gixxgp's Avatar


gixxgp
03.10.2012 , 12:08 PM | #107
No change with the Very Low setting...
Even if meeting system requirements (above minimum CPU and above recommended GPU), I'm still experiencing awful Fps, and not only in very crowded PvP but even in the fleet and in some crowded PvE environments (Kaon too...). Now i'm even tired of logging once in a week to see if they have solved the FPS issue, and going back to my former WoW account gave me all that I need to have a mmorpg with a smooth gameplay experience.
I'm only sad for this big missed opportunity of a game.
Well, at this point there's nothing else to do but to let the 38 days left of my sub to expire.
GG bioware, hope to see this game working good, but not too soon, and as a f2p. Maybe that's not going to happen too soon, or not at all, but I am still hoping that.
Yet another 5% unsubscriber

SithLordKota's Avatar


SithLordKota
03.10.2012 , 12:41 PM | #108
Purely posting here in rage out of frustration.... FPS is the last straw for me i cant stand playing a game that simply REFUSES to use my $4000 machine


always stuck @ 15-20 fps in warzone
40% CPU load
29% GPU load, only 600megs used out of my 2gig's available per card
over 4 gigs of available ram

settings set to high or low makes no difference what so ever.
low setting = 20% gpu load 15fps
high settings = 30% gpu load 15 fps

I game @ 5760x1080 in 3d surround and your telling me at that resolution this game's graphics engine will still only use 30% of my GPU's!?!?!?!?


funny thing is I get better FPS with 3d turned on and anti-aliasing cranked up because it actually force's my GPU's to work instead of sitting there idol...

Annexium's Avatar


Annexium
03.10.2012 , 12:51 PM | #109
The CPU/GPU loads are a dead giveaway that there is something wrong with the game engine. When I drop below 60fps, neither my CPU or GPU is ever even close to being maxed out. I watch my stats live on my G15 LCD provided by AIDA64, and for example on ilum riding around in the center none of my CPU cores were higher than 45% and my GPU was sitting at around 40% and yet my FPS was dropping below 60 constantly. The hardware resources are there so the FPS drops are not due to resource starvation.

Morridan's Avatar


Morridan
03.10.2012 , 12:59 PM | #110
Quote: Originally Posted by douglastroop View Post
Alright I dont know if this is the right place to put this but for some reason whenever I am near a building or go in a cave my FPS plummets. Everywhere else its good and about 90 but when I go in a cave or inside a building it drops to about 2. Any advice would be muchly appreciated. I even tried running it on its lowest possible settings and it still does it. I am at my wits end with this. Please help
Sorry if I'm late to the party, but have you tried turning off shadows?
Everything in life is given a way to measure its success/failure. Some pay attention to the metrics, some don't, but in the end they still exist. Please give us combat logs / parsing so that we may measure our successes in game.