Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Creating subscription


Ke-il's Avatar


Ke-il
12.16.2011 , 04:05 AM | #1
HELP HELP HELP! This is the 3 time me asking this with no support. Even contacting customer support doesn't help cause i can't get through, not even with email.


Whenever i try to make a subscription here on my account, it takes me to paypal, creates the purchase, and then Redirect me back to the subscription page on this site. Then it says "please wait, finalising payment" or something, with a loading circle on the page. It also says "please don't exit or refresh the page".

Within about 20 or so seconds of doing nothing buy giving a loading circle on the page, it give me an error "It appears there is already a subscription application(or request) on this account. Please remove or try again."

All it saved was my details i entered during the purchase, but the money didn't go off of my account, and it didn't create any subscription in paypal itself at all.
ALSO: ON my account summary page, where it says "get ready to play" and you have to finish the sercurity steps and all that. well i did that and it still doesn't update that page, and where it says "SUBSCRIPTIONS" it still INACTIVE and UNCOMPLETED.


SERIOUSLY! What am i supposed to do to get some help here?

Even after i removed the Half-Completed subscrition my swtor.com account, and try it again, it just gives me the same message.

How can i fix this? I want to add the subscription on my account so that i can move on and forget about it. Please fix this, i've tried it on different computers with teh same error appearing. I Can't add subscriptions from paypal!
Thanks!

Rhomb's Avatar


Rhomb
12.16.2011 , 10:43 AM | #2
Bumping this for justice. Same error for me. Is it that I still havent got full rights to start playing?

I got an email from Origin saying I had. These emails being sent out by yourselves are they the Origin ones or directly from SWtor?

DarthBrutius's Avatar


DarthBrutius
12.16.2011 , 10:47 AM | #3
Same problem occured for me, trying to pay via PayPal. In the end I decided to play with Credit Card, just for now...

marktbde's Avatar


marktbde
12.16.2011 , 10:54 AM | #4
Bump, same issue. Also can't use my credit card because i recieve the error "We're sorry, but we can't perform transactions to this credit card. Please load a different one." ?!?!!

EveyVendetta's Avatar


EveyVendetta
12.16.2011 , 11:00 AM | #5
Quote: Originally Posted by marktbde View Post
Bump, same issue. Also can't use my credit card because i recieve the error "We're sorry, but we can't perform transactions to this credit card. Please load a different one." ?!?!!
I'm having the exact same problem! Are you from the red zone like me?
DEE VIP 21/7/11 - Daniel Erickson Edition my pre-order bonus
Girl Gamer pride! | Survivor of the 29/9/11 Attack of the Email Thread Clones
Squadron 11-11-11 - Never Forget!
| . R.I.P OPOD

Rhomb's Avatar


Rhomb
12.16.2011 , 11:11 AM | #6
This is a joke.

Paypal doesnt work ,

The form doesnt work for drop downs (I.e on chrome you cannot click buttons during forms)

If you dont remember a security question you are stuck with a feeble attempt to contact customer services to recover your account.

I may as well write off my chances of playing this game early now. Thanks guys. thanks for nothing.

aiRWaLKRe's Avatar


aiRWaLKRe
12.16.2011 , 11:14 AM | #7
There are already a couple topics about this but I will post in this one too that I also have the problem with paypal, as I would rather use that, than entering CC info. So maybe we can wait a few hours or till tomorrow for it to get fixed. We still do have a couple days befor the 20th to enter subscription info, so I myself am not too worried. But if its not fixed by the 19th then I will get worried

Dandune's Avatar


Dandune
12.16.2011 , 11:16 AM | #8
It seems there is an issue with PayPal.
I subbed with CC and had no problems (red zone).

Woodspoon's Avatar


Woodspoon
12.16.2011 , 11:20 AM | #9
Having the same issue here
∑█╫╬╬╬╬╬╬╬╬۝Ξ╣◣▀▀▀▀▀▀www.thenerfherders.co.uk▀▀▀▀▀▀

Woodspoon's Avatar


Woodspoon
12.16.2011 , 11:33 AM | #10
*Update*

Deffo a Paypal issue
Tried 3 times using Paypal and it failed 3 times

Used Visa CC and it went through first time no problem.
∑█╫╬╬╬╬╬╬╬╬۝Ξ╣◣▀▀▀▀▀▀www.thenerfherders.co.uk▀▀▀▀▀▀