Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Ridiculously low FPS help


Baraduche's Avatar


Baraduche
12.15.2011 , 04:37 PM | #1
Any ideas on how to get my FPS to stay above 30-40 fps. The majority of the time its 4 fps or lower. then it will jump to in the 30's then back down to 4 for long periods of time. in the beta it was fine. Now that im in the fps basically stays at 4 fps and will at times jump to the 30's. any suggestions would be appreciated. i also just updated my drivers with no improvement.

Wapner's Avatar


Wapner
12.15.2011 , 04:39 PM | #2
Quote: Originally Posted by Baraduche View Post
Any ideas on how to get my FPS to stay above 30-40 fps. The majority of the time its 4 fps or lower. then it will jump to in the 30's then back down to 4 for long periods of time. in the beta it was fine. Now that im in the fps basically stays at 4 fps and will at times jump to the 30's. any suggestions would be appreciated. i also just updated my drivers with no improvement.
We need to know computer specs before we can make suggestions. Also, what do you have your graphics settings at?

Uyaem's Avatar


Uyaem
12.15.2011 , 04:40 PM | #3
Also, how does your computer perform in other games/programs that are using/straining the gfx card?

Baraduche's Avatar


Baraduche
12.15.2011 , 04:41 PM | #4
sorry

Nvidia gforce 9600gt
intel core 2 duo
settings on lowest possible with everything turned off
4gigs of ram

Baraduche's Avatar


Baraduche
12.15.2011 , 04:42 PM | #5
Quote: Originally Posted by Uyaem View Post
Also, how does your computer perform in other games/programs that are using/straining the gfx card?
its typically fine never had a video issue. it ran the beta fine with no choppiness or low fps

Wapner's Avatar


Wapner
12.15.2011 , 04:46 PM | #6
Quote: Originally Posted by Baraduche View Post
sorry

Nvidia gforce 9600gt
intel core 2 duo
settings on lowest possible with everything turned off
4gigs of ram
This system should do just fine, especially at low settings. I'd make sure there are no excessive background processes running.

Baraduche's Avatar


Baraduche
12.15.2011 , 04:50 PM | #7
Quote: Originally Posted by Wapner View Post
This system should do just fine, especially at low settings. I'd make sure there are no excessive background processes running.
ya i thought that was it too but i have everything off. it appears to be so random i cant pinpoint why its even happening. whats curious is that itll jump up and be crisp for like 2-3 mins as if taunting me...

Calimwulf's Avatar


Calimwulf
12.15.2011 , 04:52 PM | #8
Quote: Originally Posted by Baraduche View Post
ya i thought that was it too but i have everything off. it appears to be so random i cant pinpoint why its even happening. whats curious is that itll jump up and be crisp for like 2-3 mins as if taunting me...
Is your v-card running hot?
"For to win one hundred victories in one hundred battles is not the acme of skill. To subdue the enemy without fighting is the acme of skill."

Baraduche's Avatar


Baraduche
12.15.2011 , 04:54 PM | #9
Quote: Originally Posted by Calimwulf View Post
Is your v-card running hot?
How do i tell?

williambr's Avatar


williambr
12.15.2011 , 04:58 PM | #10
Quote: Originally Posted by Baraduche View Post
Any ideas on how to get my FPS to stay above 30-40 fps. The majority of the time its 4 fps or lower. then it will jump to in the 30's then back down to 4 for long periods of time. in the beta it was fine. Now that im in the fps basically stays at 4 fps and will at times jump to the 30's. any suggestions would be appreciated. i also just updated my drivers with no improvement.
This was a post in one of the old threads before the wipe. This is not my post but it worked for me.(at least the anistropic filter to 16 and turning the bloom off fixed all my issues, but this was all the stuff in that thread, don't ask me what it means, I'm an idiot)



~@*READ FIRST*@~ Hello, my name is CJ (you can call me Christian if you like). This is for low or mid-end machines and will only increase your FPS if you are experiencing FPS lag, not big spikes. Please note that this fix has worked for a few people, so do not be disappointed if this does not work for you. Once you have tried this fix please reply to this post if it has worked or your FPS has not improved. Thank you for reading this post, I hope it helps! MAKE SURE YOU CLEAR YOUR TEMP FILES BEFORE READING THIS! To do that, open your start bar and type %temp%, press enter. Highlight everything in the folder and delete everything. If it says you cannot delete something, press skip. Last but not least, empty your recycle bin.
----------------------------------------------------------------------------------------------------------------------------------------------------------
Before you start this fix, please make sure your client is closed and there are no SWTOR Processes pulled up.

Do not copy and paste anything in this thread into your files.

~If you are running on Windows Vista, Windows XP, just have a low amount of RAM (Random Access Memory), or just feel like increasing the performance of your system all around, please perform the steps below and look under for the RAM increase.

Steps (Click Show Spoiler):
Spoiler
1. Open your start bar.

2. Type in %appdata% and hit enter.

3. Where it says: Computer > OS:C > Users > Christian (that's me) > Appdata > Roaming, click Appdata. Click this link if you cannot find Appdata. http://api.photoshop.com/v1.0/accoun...=1322446947000

4. Open the folder that says Local, scroll down to SWTOR and open the folder. Open the folder called betatest, and then open the folder called settings.

5. Open the file called client_settings, and make sure your settings look like this (except for the settings I placed an "x" next to.):
[Renderer]
D3DFullScreen = true x
Height = 768 x
NativeHeight = 768 x
NativeWidth = 1366 x
Width = 1366 x
WindowX = 0 x
WindowY = 0 x
EnableBloom = false
AllowDepthOfField = false
TextureQuality = 1
UseMinSpecShaders = true
DynamicLightsLimit = 0
FarClipScale = 0.25
doShadows = false
PlantDensity = 0
VerticalSyncState = true
Once done, then save over the text document.

6. Open the file called Graphics_Mirror, and make sure your settings look like this (except for the settings I placed an "x" next to.):
[Settings]
Graphics_Resolution = 1366x768 x
Graphics_Bloom = false
Graphics_ConversationDepthOfField = false
Graphics_TextureQuality = loc:11012 references |This is supposed to say "colon" preferences|
Graphics_ShaderComplexity = loc:11012 references |This is supposed to say "colon" preferences|
Graphics_DynamicLightComplexity = loc:11012 references |This is supposed to say "colon" preferences|
Graphi0cs_ClipDistance = 0.10000000149
Graphics_ShadowQuality = 0.0
Graphics_GroundClutterDensity = 0.0
Graphics_SpeedTreeDistance = 0.5
Graphics_VerticalSync = true
Once done, then save over the text document.

7. Launch SWTOR and enjoy!


Support for RAM increase or Windows Vista/XP (Click Show Spoiler):
Spoiler
Quote:

Originally Posted by Eginhardt
I adjusted all my settings and it was still performing VERY poorly. I couldn't run through doors and everything was on low settings. This definitely boosted it by quite a bit.

Though, my brother also tried the same fix and it made it worse. Is there any chance it works differently from Vista to 7?
Well, Windows Vista requires 1GB of RAM to run itself. So if you have 2GB of RAM on a Windows Vista PC it would be like having 1GB on Windows 7. I would suggest for him to try Ready Boost, Game Booster, as well as, setting SWTOR to one specific processor, this is done by:
SWTOR to one processor-
1. Right click on taskbar (bar spanning across the bottom of your desktop) and open task manager.
2. Click Processes.
3. Look for SWTOR and right click it. Click set affinity and un-check every processor besides one (doesn't matter which).
4. Go through your major processes (the ones that take up the most CPU) and un-check the processor that you set the affinity for SWTOR.

Game Booster-
This is a third-party application that saves RAM by stopping processes that take up much memory. This will only end processes that are not important to running your OS or games.

Ready Boost-
This is a feature built into Windows, which started in Windows Vista, that converts space from Portable Storage devices or SD Cards. Simply plug in a USB portable hard drive or SD Card and open up "Computer". Right click the device you plugged in and go to properties. Click on the Ready Boost tab, and select the "Use this device." option. Then select how much space you would like to take off of the device and convert into RAM and press Ok.


"For your time thanks, with you happy


playing and may the force be."

Greetings all,

We are sorry to hear that you are encountering this problem.

We would suggest to try the troubleshooting steps below, in order to solve it:

1. Open Cataclyst/Ati Control Center or Nvidia control panel
2. Set Anisotropic Filtering to 16
3. Optionally, force AA to x2,x4 or x8
4. Set In-Game Anisotropic Filtering to "low".

If the issue persists, we ask that you please try the following:

1 Go to game Preferences / Graphics. Turn off the 'bloom' option from the 'Advanced' section. This should give you about 10-20 fps increase.

2- This one is for high end PCs. If your game has high fps but is still stuttering, please go to game Preferences / Graphics and turn on the 'vertical sync' option in 'General' section. This should improve your framerate issue (however, this may decrease fps in low end machines though).
Don't take me too seriously, I don't