Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Crafting menu broken/unresponsive?

STAR WARS: The Old Republic > English > Crew Skills
Crafting menu broken/unresponsive?

super_deluxe's Avatar

12.14.2011 , 06:51 PM | #1
So I picked up Cybertech for my crafting skill. I have my companion with me. I can send them on gathering missions just fine. I open up the Cybertech menu, I have a list of all the mods I can make on the left and all the mats I have on the left. Nothing I click on does anything. I can't seem to create anything. I don't get any errors, just nothing happens no matter what I click on with either button. I can't tell what I am supposed to be doing here and it is extremely frustrating.

Never mind, I'm dumb. They hide a "Craft" button down in the corner that gets covered up by other UI elements.

Solpel's Avatar

12.14.2011 , 07:25 PM | #2
Make sure your companion is not out on a mission, they do the crafting as well as gathering, and they can't do both at once. You can only que multiple crafting(5), not missions and crafting.

Zazenn's Avatar

12.14.2011 , 07:33 PM | #3
Try hitting the "N" button one or two times to close then re-open the crew skills window. I had what sounds like the same issue during beta and that always worked for me.

Holzy's Avatar

12.14.2011 , 07:42 PM | #4
Not sure if you missed it, I did for a few minutes the first time I tried crafting something, but there's a button on the bottom right side labeled "craft" which will craft the selected item provided you have enough mats. Also you can queue up to a total of 5 (I believe) things at one time which will be built consecutively by your companion.

Just to be clear, this isn't a smart *** comment. I've been a helicopter electrician for along time and I've had pilots who have been flying for over 20 years think the radio's are broken when all they had to do was turn the volume off mute...
Originally Posted by DamionSchubert
A lot of players are, well... idiots.