Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Jedi Weapons Codex Entry


Wyvernblade's Avatar


Wyvernblade
12.14.2011 , 07:48 AM | #1
I did not get this as a Jedi Knight when I completed my lightsaber. Everything I saw online says that is when you should get it.

Can anyone verify for me if they got it or if I missed it somewhere else?

Thought it might be handy to mention where it is in the codex - It is a Lore entry.

Arallu's Avatar


Arallu
12.14.2011 , 09:44 AM | #2
Same here, I'm missing 2 Lore codex entries for Tython, Rebuilding the Jedi Order and Jedi Weapons.
Will we be granted them since we've made our lightsabers already / completed everything on Tython?

Edit: Ok so I guess I need to find "Rebuilding the Jedi Order", but the Jedi Weapons one is from that last instance/story area correct?

Arallu's Avatar


Arallu
12.14.2011 , 11:33 PM | #3
Still looking, any Jedi Knight out there get the Jedi Weapons entry?

Urantia's Avatar


Urantia
12.15.2011 , 02:26 AM | #4
If I remember correctly you need to interact with the weapon station near the taxi infront of the Temple. I admit it has been awhile for me, but I think that is what you have to do. Granted if I recall...it is highlighted on your map after you construct your saber.

Early on I want to say this mission was not even in the game, but certainly was in the past few builds.
│║▌█║▌║
SQUADRON238

Malvi's Avatar


Malvi
12.15.2011 , 05:20 AM | #5
I'm also missing this codex entry. Tried heading back to the forge to see if I could get it there, but couldn't get in.

I activated the lore object by the workbench outside the Jedi Temple but I didn't get the Jedi Weapons codex.
Titans
RP | Europe

GalenDurron's Avatar


GalenDurron
12.15.2011 , 05:42 AM | #6
I'm having the same exact issue. Turned in the quest completely (where you go to Satele and she tels you to head to Coruscant) and still no update to the Lore entry.
There is no emotion (except Love, that's ok); there is peace. There is no ignorance; there is knowledge. There is no passion; there is serenity. There is no chaos; there is harmony. There is no death; there is the Force.

Wyvernblade's Avatar


Wyvernblade
12.15.2011 , 06:46 AM | #7
This is not the same as clicking the sign near the weapon customization station. That gives a different gameplay codex entry.

For the guy looking for Rebuilding the Jedi Order, I think that was a clicky chair in the first floor of the temple.

pioneerraptor's Avatar


pioneerraptor
12.15.2011 , 07:22 AM | #8
I am also missing this entry. It is 1 of 4 entries that I am missing on Tython, including 2 Bestiary and 1 Specie entry. I have already completely the Forge Quest and modified my weapon and still did not receive the lore entry.

ALivingShadow's Avatar


ALivingShadow
12.15.2011 , 08:49 AM | #9
I am also missing the codex for 'Jedi Weapon'.

I am also missing the beastiary ones for 'Wingmaw' and 'Terentatek'.

Other than those three, I have all the Jedi Knight codex.


ALSO, does anyone know or can anyone two-box/group with someone to find out if you might be able to, as a Jedi Knight (or any NON-Consular class) get the codexs reserved for Jedi Consulars by being in the story area/conversations with the Consular for them?

List is here > http://www.swtor-spy.com/codex/tython-codex-entries/29/

Is there any way, by grouping with Consulars, that other classes can get the Consular-only codex entries?
ALivingShadow
"I am not seen unless I wish to be.
The Force is my Ally. I betray all else."

pioneerraptor's Avatar


pioneerraptor
12.15.2011 , 09:02 AM | #10
I am missing those same three that you are. I sent a ticket in-game to find out if the Jedi Weapons is a bug, since during beta it was automatic.

Terentatek is suppose to be obtainable at level 10. It's possible you get it on another planet, as some entries work for multiple planets.

Wingmaw is obtainable at level 16 I believe, meaning we can't get it. Also probably obtained on another planet.

As for the Consular one, I don't think so. Mainly because there isn't room for it in the Codex, unless it will create an extra entry. But as a Jedi Knight there are only 4 Lore Entries needed for 100% on Tython.