Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Alderaan Bonus Series - BUG

STAR WARS: The Old Republic > English > Customer Service
Alderaan Bonus Series - BUG

FINNT's Avatar


FINNT
10.12.2012 , 09:16 PM | #71
It actually didn't do this with my second alt. Difference was I didn't take any new quests before bonus series was done -> no bugging. Or maybe its just random.
:laser:

GymQuirk's Avatar


GymQuirk
10.20.2012 , 03:21 PM | #72
Hit the bug, reset the "Alderaan Bonus Series" Mission and had to return to first camp to run through dialogues again. Also had to redo the "collect 5 medpacks" mission before talking to Organa. Was able to proceed to next step after repeating earlier mission dialogue.
As if I have anything worth putting in a signature...

Coldbayne's Avatar


Coldbayne
10.27.2012 , 05:55 AM | #73
I experienced same problem, for clarity when they mention above to return to first quest hub - that means the following steps must be repeated (not all as it recognises that some steps have been done already):

Reset Alderaan Bonus Series
House Organa: speak to Major Brom
Wardpost Luurdes: Speak to Lieutenant Ross
Wardpost Luurdes: Speak to Lieutenant Ross (again - mission step is skipped due to previous completion)
Recover Medpacks from Ulgo Raiding camp
Head directly to Jeren Organa - speak to Jeren Organa
Speak to Jeren Organa - mission progresses as normal now...

Gryphandor's Avatar


Gryphandor
11.25.2012 , 12:45 PM | #74
Quote: Originally Posted by AnnSaysSo View Post
Solved it: I could not turn in the medicine packs either.

I abandoned the quest.
Returned to a side room in the huge Organa Palace and spoke to Major Brom.
Got the quest back.

Did the parts they asked and I was able to turn it in.
Still not fixed anda huge necro of thread. I am going to try this out.
Gryphandor Legacy
Maldarius Juggernaut, Daríous Mercenary, Godríc Marauder

Soldaric Commando, Leoríc Smuggler, Lexiann Shadow

Gryphandor's Avatar


Gryphandor
11.25.2012 , 01:23 PM | #75
Just to let everyone know. Yes this did work but I also want to add that for me I took 2 days off of playing. Perhaps it was the two days that I didn't play that bugged the quest. It is the holiday weekend. Spent much of it with family. I did stop the questline in perhaps a odd spot when I logged out.
Gryphandor Legacy
Maldarius Juggernaut, Daríous Mercenary, Godríc Marauder

Soldaric Commando, Leoríc Smuggler, Lexiann Shadow

Grayseven's Avatar


Grayseven
11.27.2012 , 08:23 AM | #76
To reiterate with confirmation:

If Jeren Organa does not have the quest marker above him when you return to the camp simply reset...DO NOT ABANDON...the Alderaan Bonus Series.

The Quest will then direct you to Wardpost Luurdes to speak with Lt. Ross. After the first conversation you will auto complete what would have been the next quest in the chain. You have a second conversation with Ross where you will be given the quest to Recover Medpacs from a cave. Complete that quest and head to the camp where the previously bugged Jeren Organa resides (You can just head straight down the cliff from the quest cave).

You will turn in the Medpac quest and you should immediately be able to speak with Jeren Organa again after finishing the turn in conversation. This will push you past the bug in the quest chain.

I just did this and it worked without difficulty and without having to reacquire the Alderaan Bonus Series from the Palace as well as avoiding any difficulties with Customer Service concerning dropped quest chains that are (in the very words of Customer Service themselves) unsupported.

It is a sad commentary on the care a company has for its customers when a widely reported and consistent bug like this one remains unresolved and without comment for over a year, not to mention having any aspect of a game considered unsupported.
Sometimes you narfle the Garthok, sometimes the Garthok narfles you.

Rkoetin's Avatar


Rkoetin
12.24.2012 , 12:16 PM | #77
The reset thing did work. Essentially just wanna say thanks for the fix.

But what is simply beyond my comprehension is that EAWare havent done anything about this after almost one whole year went by.

Lucky this is the only functioning (hardly) Star Wars MMO around at the moment, lest people would've abandoned ship already.

YoshiRaphElan's Avatar


YoshiRaphElan
12.24.2012 , 12:24 PM | #78
I have the same problem. If you reset the Bonus Series you will not have to redo any of the quests (except the one to gather the medpacs) and as you talk to each NPC it will automatically update. Then you can correctly talk to Organa.

EDIT: Just noticed this has already been stated.

floboy's Avatar


floboy
01.07.2013 , 12:53 PM | #79
this thread has opened one year ago ... and no solve

I get the same bug (3 times, 1 : solo with my shadow, 2 : with my brother today (consular heal/ jedi knight tank).

ticket already submitted

FINNT's Avatar


FINNT
01.07.2013 , 01:22 PM | #80
This feels like bug reports get tossed to trash bin. This isn't only bug that lives through several patches.

"Best" survivors have been reported in beta (second-hand information) and they still are in game, what gives?

Example bug: Unsheated lightsabers.
-------------------------------------------------------------------------
"...If you remember, back in beta, the Jedi Knight self-buff caused us to ignite our lightsabers when cast. That would often result in a state where our characters would never sheath their own lightsabers. After several patches of this bug popping up, off and on, the self-buffs were ultimately changed to not cause us to ignite our sabers. The problem has never occurred since.

Please do the same for our companions. Thank you.
"

- http://www.swtor.com/community/showp...75&postcount=1

And yet I often speed away (speeder) lightsaber drawn as it "stucks" and won't sheat.
:laser: