Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

What is the bottleneck to make loading screens faster?

STAR WARS: The Old Republic > English > General Discussion
What is the bottleneck to make loading screens faster?

Fappa's Avatar


Fappa
01.01.2012 , 09:48 PM | #1
Is it your internet connection? Hard drive (and thus an SSD would help)? Is it your CPU?

Or is it just the servers that we have no control over?

Rhysling's Avatar


Rhysling
01.01.2012 , 09:52 PM | #2
Hard drive mostly and memory for load times. What are you using currently?

IPaq's Avatar


IPaq
01.01.2012 , 09:57 PM | #3
Quote: Originally Posted by Fappa View Post
Is it your internet connection? Hard drive (and thus an SSD would help)? Is it your CPU?

Or is it just the servers that we have no control over?
Its the process to load the graphic elements into the FP memory on the graphic card.

So OS+HD+Memory on both GPU and CPU and having free cycle on the PCI bus.

My issue was due to my old 3ware sharing the IRQ/DMA with my nVidia 9800 GT.

Replaced it for a 560 TI and voila sub 20s load time despite my old 3Gbps only 3ware card.

Fappa's Avatar


Fappa
01.01.2012 , 09:57 PM | #4
Quote: Originally Posted by Rhysling View Post
Hard drive mostly and memory for load times. What are you using currently?
Just a normal 7200rpm HD. I guess I was just wondering if the load screen when you change zones was entirely my hard drive, or if it had anything to do with the server.

ChillBill's Avatar


ChillBill
01.01.2012 , 09:58 PM | #5
I'm using a 128MB SSD, so I don't think the bottleneck is the drive. I'm also using a 50Gb connection, so I don't think that's it either.

I just think there's a lot of work they need to do to better optimize their servers. Never had a game take so long to zone... and I played EQ.

It's really not too big a deal until you get into class quests that send you all over, but still I really hope they improve this.

ChillBill's Avatar


ChillBill
01.01.2012 , 10:03 PM | #6
Quote: Originally Posted by IPaq View Post
Its the process to load the graphic elements into the FP memory on the graphic card.

So OS+HD+Memory on both GPU and CPU and having free cycle on the PCI bus.

My issue was due to my old 3ware sharing the IRQ/DMA with my nVidia 9800 GT.

Replaced it for a 560 TI and voila sub 20s load time despite my old 3Gbps only 3ware card.
Hmm, I'm using a 6970 and I still get terrible load times. Think there are any settings I could tweak via CCC to improve it?

Would love to see <20s load times lol

IPaq's Avatar


IPaq
01.01.2012 , 10:06 PM | #7
Quote: Originally Posted by ChillBill View Post
Hmm, I'm using a 6970 and I still get terrible load times. Think there are any settings I could tweak via CCC to improve it?

Would love to see <20s load times lol
Have a "real" pro look at your computer?

Chrismilk's Avatar


Chrismilk
01.01.2012 , 10:07 PM | #8
I'm guessing an SSD drive would speed things up.

They are quite expensive though.

belialle's Avatar


belialle
01.01.2012 , 10:09 PM | #9
I am sorry that so many of you are having issues with load times. More RAM might help, possibly...depending on your situation.

My load times are actually pretty good, though it does take a pretty long time to swap from one shard to another. Other than that, though, it's pretty speedy for me. Hopefully this is something they patch up sooner rather than later. I know how annoying loading screens can be.

Zeila's Avatar


Zeila
01.01.2012 , 10:10 PM | #10
Quote: Originally Posted by ChillBill View Post
I'm using a 128MB SSD, so I don't think the bottleneck is the drive. I'm also using a 50Gb connection, so I don't think that's it either.

I just think there's a lot of work they need to do to better optimize their servers. Never had a game take so long to zone... and I played EQ.

It's really not too big a deal until you get into class quests that send you all over, but still I really hope they improve this.
Pretty much this, the game needs to be optimized in future builds. I've got a NASA computer and still loads slow for me.