Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Alderaan Exploration..impossible?

STAR WARS: The Old Republic > English > General Discussion
Alderaan Exploration..impossible?

Tuzark's Avatar


Tuzark
12.31.2011 , 11:32 PM | #1
I am trying to fully explore "The Juran Mountains" in Alderaan, but even though i've been everywhere on the map three times i still can't find the last place i'm missing.

This is what i have so far:

http://img.photobucket.com/albums/v4..._15_835214.jpg

I've been going to every "black spot" to try exploring there, i've gone to every area that looks like it could be it, but nothing. Any suggestions or help would be welcome. :P
"Each event is preceded by Prophecy.
But without the hero,
there is no Event."
-Zurin Arctus | the Underking

Pravis's Avatar


Pravis
01.07.2012 , 10:48 PM | #2
I have the same exact map. All other zones are fully explored except for this one map. All the blank hexes are mountains so how do you explore this? I am a bounty hunter for what its worth.

Orvish's Avatar


Orvish
01.07.2012 , 10:51 PM | #3
Yeah. It bugs the hell out of me too.
"You've lost perspective like a picture by Escher; it's the pressure."

Dark Side and loving it.

ZeroGravTrooper's Avatar


ZeroGravTrooper
01.07.2012 , 10:58 PM | #4
I spent like two hours trying to fill out that map. D:
Glad to see it's not just me.
Warriors of the Shadow --- Vanguard --- Zero
Quote: Originally Posted by Blagojevich View Post
Blagojevich approves.

JHarkrider's Avatar


JHarkrider
01.07.2012 , 11:00 PM | #5
According to the shading, the very southern tip of the map still needs to be uncovered.
.

Talmino's Avatar


Talmino
01.18.2012 , 05:35 PM | #6
JHarkrider is correct it is the very southern tip of the map. It's called Alsakan Overlook.

Akkando's Avatar


Akkando
06.01.2013 , 09:34 PM | #7
Just in case a search engine brings you here, this is what you need to do:
Like Talmino says, you're looking for the Alsakan Overlook. The coordinates are around 1617,1500. There is a republic quest (A Historic Endeavor) given by Maelrich Alde at 1379,1252. You don't need the quest to get to the top, however. Follow the path to the top of the mountain. This will take you up to the Mount Tessef Ruins. When you get to the top, you'll see a basin to the south. That's where you need to go. Get near the 1617 axis and jump down.
CE Owner and beta player
Republic toons on Begeren Colony: Alerron, Akando, Mik'hael, Elyon
Empire toons on Begeren Colony: Zodeus, Mikhale, Xodius, Akkando
Christian Gamers Alliance

Drew_Braxton's Avatar


Drew_Braxton
06.02.2013 , 07:43 AM | #8
It's possible, and galactic explorer is finally able to be obtained. Some planets have very out of the way spots to explore. The southern tip of alderaan and there's one on Voss and Belsavis that are not obvious so take some wandering around to find. Now if they would fix the lore bugs and beasts of ilum I can finish those.

Off to wander around to find that SIS Watchman which is allegedly possible, but still not found.
Mains: Braaxton (pub) / Noomo (Imp) The Shadowlands
Characters: 35 level 70's, 2 level 30's
Achievement Count: 51,720
Decoration Prestige: 380,882 (761,764) Enjin Page

wildcoast's Avatar


wildcoast
06.05.2013 , 01:44 PM | #9
I've finished this achievement a couple weeks ago, I remember the final spot I ran UNDER a bridge and along a stream at the bottom of that area to get the final spot to unlock. Hope that clue helps.
Trooper Thavious
203rd Republic Expeditionary Legion

Arlon_Nabarlly's Avatar


Arlon_Nabarlly
06.05.2013 , 02:06 PM | #10
Quote: Originally Posted by JHarkrider View Post
According to the shading, the very southern tip of the map still needs to be uncovered.
This.

I understand the OPs confusion, I had trouble with this on multiple toons and would stare at my map for like 20 minutes before I figured it out. It would help if there weren't all the mislead empty hexs in the middle that are on top of mountains.