Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

FIX: Stretched/squashed graphics (WORKING)

STAR WARS: The Old Republic > English > Customer Service
FIX: Stretched/squashed graphics (WORKING)

RedRangerABC's Avatar


RedRangerABC
12.29.2011 , 08:02 AM | #1
Hello,

since my wife and me both had issues regarding stretched/squashed 3d graphics (UI was fine) I took on the quest to solve this problem.

Obviously this is a very long and elaborate description, but I wanted to delve a little into the background instead of just saying where to click what.


The problem:
Every monitor transmits EDID data containing possible resolutions, frequencies and other data. Some manufacturers are lazy and just add stuff that won't work (4:3 resolution on 16:9 screens and vice versa).

Almost every application uses the current resolution to get the aspect ratio, but SWTOR does not. It reads the EDID information instead.


The solution:
The EDID info is stored in the registry, too, but Win7 prioritizes the data from the actual monitor. However Microsoft implemented a way to add EDID_Override information to the registry. You will have to create a new inf file that adds the correct override entries in the registry.

How To:
You will need 1 or better 2 little tools

1) Extron EDID Manager (http://www.extron.com/download/softw...aterial=2&id=E)
2) Entech Monitor Asset Manager (http://www.entechtaiwan.com/util/moninfo.shtm)

Both programs can import EDID information from the registry or monitor.

Use the EDID Manager to navigate through the EDID infos until you find the biggest resolution that is not supported by your monitor.

Example:
1400x1050 native [4:3], but EDID said 1440:900 [16:10]. Since one of the X or Y values is higher than the actual biggest SWTOR will think this aspect ratio is the one that counts.

1400x1050 is hex 90 40, for example. To set this resolution to "unsupported" load the EDID information in the Monitor Asset Manager.

The EDID data is displayed in the same way (as in EDID manager, a block of Hex numbers), so you can just look for the right Hex pairs in the EDID Manager and then switch to Monitor Manager and look through the numbers until you find it.

In Monitor Info now go "Edit" and untick "Read-only" to be able to write changes.

Change all unsupported resolutions (there may be multiple entries, one for each resolution-frequency pair (1400x1050 - 60Hz, 1400x1050 - 75Hz and so on) to 01 01.

Then click on "File -> Create Inf" in Monitor Manager and save the inf somewhere, where you will find it again.

Now go to your Windows Device Manager, and update your monitor driver. Click through the dialogues until you are able to manually select an inf file from your hard disk. This will install the new modified inf file.

In your device manager your monitor will now be named <monitor name> (<driver> EDID Override).

Finished.
FUS RO DAH!

Jediminstrel's Avatar


Jediminstrel
12.29.2011 , 08:31 AM | #2
/Bump
I think this is a good article

RedRangerABC's Avatar


RedRangerABC
12.29.2011 , 07:45 PM | #3
/shameless bump

I have been looking for ages for this solution and think anyone should be able to get a shot at fixing this.

For ATI users its even easier, they can override the EDID settings in the Catalyst Control Center (Display tab I think)
FUS RO DAH!

Wauder's Avatar


Wauder
01.03.2012 , 12:54 PM | #4
Hi,
I tried this, but when I want to update monitor driver it did nothing. When I checked my setting with EDID manager it was same as before update. I also tried to rewrite files in register manuly, but it didn't work too.
Ples if you have idea what I am doing wrong or why it isn't working, could you please give me a help?

Flamespidey's Avatar


Flamespidey
01.06.2012 , 11:38 AM | #5
I tried this as well but I'm having the same problem as Wauder. Any info?

Phyrexianwrath's Avatar


Phyrexianwrath
01.07.2012 , 07:59 PM | #6
Bumping this as I have the same problem and have tried the above solution. However the hex values in the viewer was not matching up with the ones in the editor.

Aidan_Pride's Avatar


Aidan_Pride
02.03.2012 , 10:53 PM | #7
last server side update did fix the problem for me...no clue why. nothing in the patchnotes.

Sheyoni's Avatar


Sheyoni
02.20.2012 , 11:04 PM | #8
I downloaded the program, but I'm really at a complete and total loss for what to do with it. How do I even get it to load my monitor's info? -_-

killerOFgiants's Avatar


killerOFgiants
03.31.2012 , 05:42 PM | #9
Another possible solution that I found to work for me: I'm currently running this game on a mobility radeon x1600 (I know, technically not supported) and was having this issue with everything being stretched and distorted. I fixed it by installing an old driver pack from omegadrivers. Seems that some cards are no longer supported by CCC now, and installing an old driver fixed it for me.

Alemu's Avatar


Alemu
04.24.2012 , 08:22 AM | #10
did it all, it still displays that 1920-1080 is my native resolution and there are no differences.
Still unaware of what to do, this doesn't help at all.
Forgive me, Father... for I. Will. Sin.