Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

issue with Jedi Consular mission, Chapter 3, "Chaos and Harmony"

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
issue with Jedi Consular mission, Chapter 3, "Chaos and Harmony"

willis-thompson's Avatar

09.14.2013 , 06:47 PM | #1
Me and my partner both play SWTOR, and he's having trouble completing the very last part of this mission, so he's asked me to post this asking for help. His character starts the final conversation with Supreme Chancellor Saresh, and a cut-scene begins- then the screen promptly turns black and the game crashes.
We've been trying for a month now to find a solution to this, but nothing's worked so far; can someone please help?

NicAX's Avatar

09.14.2013 , 09:07 PM | #2
What have you tried so far? Just so we're not repeating things.

Have/can you try with a different PC?

Have you sent a ticket to support in game?

JettJurott's Avatar

09.20.2013 , 09:35 PM | #3
I'm having the same issue as well. The game just freezes as soon as the cut scene begins. I have had no issues with the game until now.

JettJurott's Avatar

09.21.2013 , 09:51 PM | #4
Update: I wound up lowering all the video settings (just for this scene)- it must be the volume of characters in the scene. There's a whole lot! Then it loaded okay. Afterwards, I revamped the graphics back to where I had them.

willis-thompson's Avatar

10.18.2013 , 06:29 AM | #5
We turned the graphics settings down to 'low; and it worked fine, at last.
On top-of the range laptops, which is silly, but at least it worked

bahudson's Avatar

10.05.2015 , 04:52 AM | #6
Must try that as well as for the inquisitor quest. thanks, jet!