Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

*** is this all about, Bioware? Seriously?!?

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
*** is this all about, Bioware? Seriously?!?
 

Highborne's Avatar


Highborne
10.05.2015 , 11:11 AM | #1
OK, I'm already rather peeved at the ongoing stagnation of SWTOR, but that's neither here nor there, because I have two very specific beefs with things as they are:

1) Why no notice of the "maintenance" earlier today? Seriously annoying.

2) After having problems with the launcher, when I can FINALLY log on, I have to start downloading the grandmother of all patches, but with no changes to the game except the flashy-looking login screen. NOT WORTH IT, Bioware.

Incidentally that "NOT WORTH IT" is what I'm pretty close to saying about SWTOR in general, what with the recent butchering of the Cartel Market, the pathetic "storyline" that amounts to half an hour's gameplay....three years with SWTOR have made it more and more clear to me that Bioware don't know how to run an MMO. Even the STAR WARS (tm) label can only cover up your gross incompetence for so long...

PlumbobGreen's Avatar


PlumbobGreen
10.05.2015 , 11:14 AM | #2
How did you manage to log on? I've been trying for 2 hours :'(
Want a free 7 day subscription and other cool stuff? http://www.swtor.com/r/zWwtFP (Make sure you are logged in before clicking the link)

Highborne's Avatar


Highborne
10.05.2015 , 11:24 AM | #4
Quote: Originally Posted by PlumbobGreen View Post
How did you manage to log on? I've been trying for 2 hours :'(
I used Option II from here: http://www.swtor.com/community/showthread.php?t=419492

It went through another cycle or two of "patching, please wait", but it really WAS patching, not just spinning around in circles - so be patient

PlumbobGreen's Avatar


PlumbobGreen
10.05.2015 , 11:35 AM | #5
Quote: Originally Posted by Highborne View Post
I used Option II from here: http://www.swtor.com/community/showthread.php?t=419492

It went through another cycle or two of "patching, please wait", but it really WAS patching, not just spinning around in circles - so be patient
Now I am able to log in but the play button is faded and its says unable to retrieve patch data. Please check network connection (208)
Want a free 7 day subscription and other cool stuff? http://www.swtor.com/r/zWwtFP (Make sure you are logged in before clicking the link)

Adric_the_Red's Avatar


Adric_the_Red
10.05.2015 , 11:51 AM | #6
Quote: Originally Posted by Highborne View Post
Why no notice of the "maintenance" earlier today? Seriously annoying.
There was notice given, in this thread, and also in the Launcher.
"Your deaths are useless if they do not inform". -- The Shroud
My referral link. Click for free stuff.