Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Maintenance: September 20th, 2013

STAR WARS: The Old Republic > English > General Discussion
Maintenance: September 20th, 2013
First BioWare Post First BioWare Post

Ako_and_Riko's Avatar


Ako_and_Riko
09.20.2013 , 05:43 AM | #11
then how about 1am to 3am CET, it would be over right before the majority of players globally going online

AmberGreen's Avatar


AmberGreen
09.20.2013 , 05:51 AM | #12 This is the last staff post in this thread.  
All servers are now available! Thank you for your patience.
Amber Green | Live Services Specialist
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.] [Dev Tracker]

Ako_and_Riko's Avatar


Ako_and_Riko
09.20.2013 , 05:54 AM | #13
Launcher says unavailable so don't you use your jedi tricks on us :3

Adoniyah's Avatar


Adoniyah
09.20.2013 , 06:09 AM | #14
Did they fix the missing HK-parts and mission reset problem?

GatorAndy's Avatar


GatorAndy
09.20.2013 , 07:22 AM | #15
Quote: Originally Posted by Adoniyah View Post
Did they fix the missing HK-parts and mission reset problem?
No. This was for the issues at CZ-198.

It's in the patch notes, which are linked in the first post here.

Also, here: www.swtor.com/patchnotes

lynx_skylark's Avatar


lynx_skylark
09.20.2013 , 02:33 PM | #16
So is there a reason as to why I cannot find any servers?? I am on the red eclipse and cannot see any not even in north america, is it maintenance or my account?

sabretruthTiger's Avatar


sabretruthTiger
09.21.2013 , 12:53 AM | #17
I cannot patch the game after the most recent patch 09/20/2013. It has been stalled at 46.7% for a day. Nothing on my system has changed so it must be the patch. I've tried repairing the launcher, restarting etc. Is something going to be done about this?

Cheers

Aaron

sabretruthTiger's Avatar


sabretruthTiger
09.21.2013 , 01:04 AM | #18
Quote: Originally Posted by sabretruthTiger View Post
I cannot patch the game after the most recent patch 09/20/2013. It has been stalled at 46.7% for a day. Nothing on my system has changed so it must be the patch. I've tried repairing the launcher, restarting etc. Is something going to be done about this?

Cheers

Aaron
I guess I should investigate all threads instead of posting like a whiny noob

Deleting the Bitraider folder does indeed work

Amarador's Avatar


Amarador
09.25.2013 , 02:06 AM | #19
I cant start a new thread. This is about the 9/24 patch. As it was this was a disaster. I am still updateing the patch after 7 hours so far. It is difficult for me to believe that every patch is an emergency. Every 2 to 4 days is excessive. I also believe that you are not testing patches by random sampling methods.

Feature request - Restrict patches to no more than once per week on a given scheduled day. Tuesday for example since all "Weekly's" are reset. Make sure all players know and understand the schedule. This should also allow you to do more thorough testing.

Note: Since the introduction of BitRaider, patching has been painfully slow. Usually taking me 1 hour. I have disabled BitRaider permanately because of this update.

2nd feature request. How about introducing Guild houses or Galaxy class ships. These should have the ability to decorate from drops in operations, vendor sales, and Cartel Market. I know I would love to buy a personal home on some given planet that I can decorate and have a little extra storage.