Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Error 311 AGAIN??????

First BioWare Post First BioWare Post

jgceron's Avatar

06.12.2013 , 04:15 PM | #1
Why am i getting this error again, BIOWARE? With the previous patch, the only thing that worked for me was reinstalling the whole game. And that itself didn't work until the launcher realized it was outdated. So, why again im getting this "Unable to retrieve patch data. Please check network connection (311)" message? Do I have to delete and install the game everytime a new patch comes? FIX THIS, pleaseĦĦĦĦĦ

Bronholz's Avatar

06.12.2013 , 04:33 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings jgceron,

Thanks for contacting us.

There are a few steps below that I would like you to try:
  • Downloading the latest available version of the launcher and setup files from here.
  • Try running the Repair function from the launcher, this will check for and repair any corruptions in your game files. You can find this by logging into the launcher and clicking the cog icon.
  • Removing and Re-adding the launcher (launcher.exe) and the game client (swtor.exe) to the exceptions list for your Firewall/Anti-Virus.
  • Flushing your DNS cache
  • Please ensure that the Ports that the game requires have been opened on your launcher.
  • Restarting your computer with a Clean Boot, to see if this changes the issue at all.
Please try the above and let us know if they have an effect on the issue.

Additionally are you using any programs such as peerblocker? If so please try with this turned off.

Thanks for your patience.
Bronholz | BioWare Customer Service – Forum Support

jgceron's Avatar

06.12.2013 , 08:43 PM | #3
what part of what i wrote above you don´t understand? I did ALL that and didn't work. You think i'm going to try any of this again? If, by the time of my subscription renewal, i can't patch the game, consider my subscription ended. Period.

Beruthien's Avatar

06.12.2013 , 08:45 PM | #4 Click here to go to the next staff post in this thread. Next  
Hello jgceron,

Could you please post your most recent Launcher log?

Thank you!
Beruthien| BioWare Customer Service – Forum Support

jgceron's Avatar

06.12.2013 , 09:25 PM | #5

Beesodd's Avatar

06.13.2013 , 02:38 AM | #6 This is the last staff post in this thread.  
You mention taking a few steps previously. Can I check if you have tried restarting your machine in Safe Mode with networking? If you haven't already, please do so.

Another thing that may help is to navigate to the main game folder and delete the retailclient_swtor.version file and the "patch" folder.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

OwenBrooks's Avatar

06.13.2013 , 03:21 AM | #7
Just to be certain this is a simple thing to do , just run the fixit and reboot , just in case

jgceron's Avatar

06.13.2013 , 08:35 PM | #8
Well, the patch worked without any problems today at 5:00 pm ET. I did not do ANY of the solutions provided in this post. As with many other issues (lag, artifacting, etc) my guess is that these launcher, patching issues are for BIOWARE to fix on their end. Please, for the next patches, allow us to manually download them so nobody will be left without playing a single day. Thank you.

OwenBrooks's Avatar

06.14.2013 , 07:17 PM | #9
Ok for starters you need to understand what error 311 is , what is it , it is an inability of the launcher to download the files , why can be from a number of reasons, most are AV/Firewall related or internet related , so your trouble was internet related that is obvious. case closed.

jgceron's Avatar

06.18.2013 , 02:25 PM | #10
Hi. I´m having again this problem. So, I guess case is not closed at all.