Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Error C7.

First BioWare Post First BioWare Post

Akarrian's Avatar

04.29.2013 , 05:11 AM | #1
Hi, i'm not all too good with computers, but i downloaded SWTOR over night, and when i tried to play it came up with that error, i've seen you've asked for DxDiag before on other posts, but i don't know what i'm doing really if someone could help?

if someone could help with the problem, and inform me how to fix it, that would be greatly appreciated ^-^

Beesodd's Avatar

04.29.2013 , 05:16 AM | #2 Click here to go to the next staff post in this thread. Next  
Hi Akarrian,

The machine you're using is below the minimum specs to play the game, which is what the error code c7 indicates. However, maybe we can get the game up and running, albeit with limited performance.

The drivers (the software to run the hardware) for your graphics card are quite old, and in many cases using up-to-date drivers will help even old hardware to run newer games. Following the link below, update your drivers from the AMD/ATI link, and then see if the game will run. If it does run for you, be sure to reduce the graphic settings as low as possible and disable shadows/bloom, as this will help the game to run.

Minimum Specifications:

Drivers update link:

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Akarrian's Avatar

04.29.2013 , 05:39 AM | #3
According to AMD Driver Autodetect, my drivers are the latest ones for my version.
Looks like it's time for a new PC.

Vansome's Avatar

04.29.2013 , 01:12 PM | #4
I've also been having this issue. I've been a loyal player of this game since early access, and have run into an issue. Upon attempting to launch the game after patching to 1.7.3a and updating the launcher for the Display Name Only update, I have encountered computer error C7. The error description states my computer may be incompatible with the game. This isn't right since I've been using this same computer without issue since launch. I have tried restarting my computer, to no avail. Please help me!

Here's my DXDIAG:

I don't know what happened after 1.7.3a, please help! I want to be able to play on my desktop again instead of my laptop!

"Peace is a lie, there is only passion..."

--Exerpt of the Sith Code

OwenBrooks's Avatar

04.30.2013 , 01:30 AM | #5
Re-install your video drivers the below need to say enabled in the dxdiag

DDraw Status: Not Available
D3D Status: Not Available
AGP Status: Not Available

Vansome's Avatar

05.02.2013 , 02:49 PM | #6
Can you or someone tell me how to do this please? Thanks a lot for your response
"Peace is a lie, there is only passion..."

--Exerpt of the Sith Code

Bronholz's Avatar

05.02.2013 , 03:09 PM | #7 This is the last staff post in this thread.  
Greetings Vansome,

Using the information from your DxDiag go to your card manufacturer's site (AMD). Here you can search for and install the latest driver versions for your card.

Bronholz | BioWare Customer Service Forum Support