Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Ability Delay

Philastra's Avatar


Philastra
04.19.2013 , 02:53 PM | #1
Been seeing ability delay in PVP and PVE, It happens randomly it seems. I'm a BH and when I hit an ability it will just sometimes not fire then I press the ability several times still not firing, but then after around 3 to even 5 secs it will work. This is pretty game changing especially if your healing and or PVP'n and you trying to finish someone off and your abilities do not fire for 3 to 5 secs will result in deaths.

Anyone else seeing this, and or do you know about this BW?
It only takes one candle to scare away the dark, or just hire a Bounty Hunter....

Deluxe_'s Avatar


Deluxe_
04.19.2013 , 02:57 PM | #2
I just mentioned this on another thread:

http://www.swtor.com/community/showthread.php?t=628435

Quote: Originally Posted by Deluxe_ View Post
It happens to me a lot when using Storm (Vanguard leap). I fire the ability and... nothing. GCD just keeps refreshing as I frantically try to activate other abilities (for some reason this is especially common during Huttball). But the funniest part is that, 4-5 seconds later, my Vanguard will finally leap onto the target, no matter how close or far from it. So now when this happens I try and play with it: it looks so crazy when you land a 40m leap, but it's just so funny when you leap on your target from 1-2m away.

Caddax's Avatar


Caddax
04.19.2013 , 03:04 PM | #3
I've been seeing this also. I've also seen it with some (not all) companions when you click on a crafting node for them to pick up but usually they just stand there for those and I end up doing it myself.
Everyone expects the Sith Inquisition.

timewyrm's Avatar


timewyrm
04.19.2013 , 03:06 PM | #4
Same with me (ToFN)

Philastra's Avatar


Philastra
04.19.2013 , 09:04 PM | #5
Hopefully they see this, i'm glad i'm not the only one that's seeing this. Not so glad about the fact its happening Hopefully we can get a word from Eric on this.
It only takes one candle to scare away the dark, or just hire a Bounty Hunter....

QuetzoCyote's Avatar


QuetzoCyote
04.19.2013 , 10:43 PM | #6
I've been playing since launch, and have been reading about ability delays ever since. Fortunately for me, I've never had any problems with gcd or ability delay. There were literally MILES of threads on these forums about it from others though. But supposedly they fixed it, and all was good in the world.
Then they go and make changes to alacrity and push out the "expansion" and now I have ability delay. It is awful, and hopefully it's just a simple fix that doesn't take a year this time around. There is a sporadic 3-5 second delay in ability activation, and it would make PvP unbearable, so I'll stick to the PVE grind for now.

Glorthox's Avatar


Glorthox
04.20.2013 , 12:26 AM | #7
Most have seen it and EAware refuses to address this issue. Ability delays and the new hardmodes don't mix considering the new hardmodes are not forgiving in the least. Not to mention the high repair bill for wipes.

Thebetts's Avatar


Thebetts
04.20.2013 , 12:32 AM | #8
The same thing has happened to me during Huttball on my Sorc, when I try to Extricate the Ball Carrier across the line, sometimes I have to smash the button two or three times before it goes.

Quite annoying.