Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Catalyst - get infected by a Rakghoul....

STAR WARS: The Old Republic > English > General Discussion
Catalyst - get infected by a Rakghoul....

Mowermanx's Avatar

02.09.2013 , 06:53 PM | #11
Quote: Originally Posted by KariTalRathe View Post
Oh well, maybe they changed the mission then. I just did it back to back this week on two new alts and a pack of wee ones with no mommy ghoul infected me fine.
Indeed, the last time I done this mission, and i've done it at least 9 times, a weak mob infected me, and I remember a lot of people having trouble early on with this mission, so I wouldn't be surprised if they did change it.

AgentJacen's Avatar

02.09.2013 , 06:56 PM | #12
I just stood there and got attacked by a rakghoul and infected. I have to admit, this is one of the ONLY good quests on Taris.
"Only I've been both Jedi and Sith, and found clarity in the force." -Revan

Ighten's Avatar

02.10.2013 , 05:57 AM | #13
Just did this on an alt and the first Rak that came along infected me.. Are you sure your not over beating them or letting the comp take the aggro

AsheraII's Avatar

02.10.2013 , 07:05 AM | #14
If you log off after picking up the mission, it seems to bug out more often when you log back in and try to do it. So either reset it from your mission screen, or abandon it and pick it up again (you can actually pick it back up).

Easiest way to do this: Set your companion to PASSIVE, and turn it back to agressive once you get infected (or when you don't seem to get infected eventhough you have a dozen stacks of infection on you, in which case you'll want to reset the mission again)
. . . . . . ▀‼▀▀▀▀
|####/ ( /==|####/

AlexDougherty's Avatar

02.10.2013 , 07:44 AM | #15
The first time I did this mission I found that it works if you go to the waystation to the south first, then try to get infected, otherwise I just couldn't get "infected" for the mission, I got the disease causing damage but not "Infected". But after finding the waystation to the south, the one with the med-bot you see after getting infected, then I got infected in seconds, a bit of a bug, but solvable.
Peace can be found, above all passions. Through passion, I may gain strength.
Through strength, I may gain power. Through power, I may gain victory.
But for every enemy fallen, a new foe rises.
For every chain broken, new chains bind me. Only the Force can set me free.

Garanaga's Avatar

02.10.2013 , 09:13 AM | #16
The red Rakghouls are the ones I always get infected by, and on each and every character it took 1 group to get infected. 1st time every time (unless of course someone thinks they are doing you a favor and kills them) Oh dear lord how irritating is that. I do not see how anyone can be having problems unless they are fighting the wrong mobs.

Laerian's Avatar

02.10.2013 , 09:50 AM | #17
Yesterday I started the quest, then I traveled to the fleet. When I crossed to the "green" area the quest "failed" and the timer got reseted. After that I had one "failed" message everytime I entered or exit an area.

After that, in Taris, when I wanted to continue the quest and get infected I reseted the quest but it didn't work, after several tries. So I had to abandon and take the quest again (it worked at the first try).

KariTalRathe's Avatar

02.10.2013 , 09:54 AM | #18
Quote: Originally Posted by Garanaga View Post
Oh dear lord how irritating is that. I do not see how anyone can be having problems unless they are fighting the wrong mobs.
People have problems because the mission is buggy, not because the mobs are 'wrong'! Just as the Alderaan bonus mission is buggy, you have to reset this mission sometimes in order for it to 'update'. As I said earlier, I have had to reset on all characters that have done this particular mission and while Ash may have a point up there about it happening when you log out this is definitely not the only culprit as I do it immediately I get the timer (i.e. take the mission) and it still has never worked first time for me.