Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

GTN Searching

Allondro's Avatar

12.20.2012 , 03:16 PM | #1
Why is the search function on the GTN so clunky? Evidently, if you don't know the exact name of something and every category it falls under, you won't get any search results. Either that or there is absolutely NO armour at all for sale on the GTN. Very frustrating.

tiltion's Avatar

12.20.2012 , 03:55 PM | #2
Armor searching is pretty easy. Just set it to "Armor" and then the class (heavy, medium, light or adaptive). You can search like that no problem or you can set it to search specifics (helm, chest, etc). Maybe you have a character in the name field?
"...another reason why you can’t mail your incredibly dirty messages to members of the opposite faction. ...Empire players would start sending horrific messages – and I mean horrific – so that’s what we want to avoid." - Creative Director James Ohlen

Beemerchick's Avatar

12.20.2012 , 04:43 PM | #3
Also check to see if you have it set to search for a specific stat, (i.e. Willpower, Strength, etc. That dropdown is at the bottom of the menu), "useable by" (which seems to limit searches if you are searching for a companion), or a certain level range.

Jason_T's Avatar

12.20.2012 , 04:48 PM | #4
You can search by partial name of an item even without using the drop downs. At one point it only would take full word searches though.. i.e. "Blastech sniper rifle" could be found by just typing "blastech" but not by "blast".

I'm not sure if it still works that way since I havent tried recently for partial word searches.

Athena-Nike's Avatar

12.20.2012 , 08:45 PM | #5
I use it when I find something I want but don't want to scroll through the pages to find the cheapest one to buy. Just search the name and sort by price

Other then that I just use the general search parameters to find stuff (armor-body-adaptive or whatever)

Kerensk's Avatar

12.22.2012 , 02:46 PM | #6
It's actually pretty good now. But when you search by name try to take off all the other limitations except maybe the type of item you're looking for. You need 3 letters to search but it can be anywhere in the name. Be sure the level is set between 1 and 50 as some items with level restrictions always show up as level 1.

And never used the "usable by" Menu option. It's obsolete and buggy.
The Harbinger, Piett Legacy
“It's an older quote but it checks out. I was about to clear it. ”

ziphii's Avatar

12.22.2012 , 06:08 PM | #7
The most annoying thing is searching for prices on stuff I want to sell... The default prices are almost always wrong, and if I don't type in the whole name in the search box, I end up with 20 pages instead of 2 to look through. Wish we could have something like auctionator.

Allondro's Avatar

12.27.2012 , 12:59 AM | #8
I hate to admit WoW is superior in anything, but it has a great auction house. The best one out there was in City of Heroes, but that's gone now.

Zarakaar's Avatar

12.27.2012 , 08:14 PM | #9
Be sure you do not select any "Usable By" option. I don't think that has every worked correctly, and it always returns empty search results for me.

Marctraider's Avatar

01.01.2013 , 09:56 AM | #10
I kinda have to agree, the GTN system is really clumbsy, specially for new players its very hard to get a good overview of whats on there,

furthermore the search functionality is totally crap, you are required to fill in at least 3 letters for something to come up if you search any, and the way it searches for keywords is a bit weird.

I must give STO that, the exchange there is much better, it simply searches for the exact thing you write down, or a part of that, an error and it doesnt show anything at all.

Thats how it should work
Cyrix 166MHz - 128MB EDOram - Tseng Labs WD4000 1MB VRAM + 3DFx Voodoo 2 12MB 2x SLI - Quantum Bigfoot 6GB - Adlib Gold 8-bit soundcard with real OPL3 Synthesis.
--- 45~ FPS in Fleet/Warzones ---