Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Error 3003

First BioWare Post First BioWare Post

aenfair's Avatar

11.16.2012 , 01:25 PM | #11
Repair complete, error remains.

FaramirTFK's Avatar

11.16.2012 , 01:28 PM | #12
yep, same scenario, tryed compatibility options, firewall, router and antivirus and still same error

Morticon's Avatar

11.16.2012 , 01:44 PM | #13
Same error not helping

teckthekid's Avatar

11.16.2012 , 01:48 PM | #14
Choosing Windows XP Service Pack 3 resolved my issue and I have no more error on connection.
Let know if it helped anyone else.

FaramirTFK's Avatar

11.16.2012 , 01:52 PM | #15
Not me, tryed all compatibility options and nothing, updated graph drivers nothing either, XDD

Tirvaak's Avatar

11.16.2012 , 01:57 PM | #16 Click here to go to the next staff post in this thread. Next  
Thanks for letting us know teckthekid,

Hopefully this will help others, but if not I'd like you to try and run fixlauncher.exe from the swtor installation. From what aenfair described, with the knowledge base not being available as well as the updating message of the day, there could be a chance that fixlauncher might help.

Give this a try and let me know if there is a difference.

Tirvaak | Bioware Customer Service - Forum Support

FaramirTFK's Avatar

11.16.2012 , 02:06 PM | #17
Finally i got u, ok, my antivirus even when i closed him seems blocking the conexions, so i put launcher.exe as exception, and error gone.

Good luck ppl, i hope this helps a little, and sorry for my english, sucks a lot XD

Tirvaak's Avatar

11.16.2012 , 03:21 PM | #18 This is the last staff post in this thread.  
Hi FaramirTFK,

Glad to hear you're back in.

Could anyone else that was encountering this issue please let me know if you have been able to get back game by using the steps mentioned in this thread?


Tirvaak | Bioware Customer Service - Forum Support

aenfair's Avatar

11.16.2012 , 09:39 PM | #19
I was having all sorts of issues, so I uninstalled and reinstalled. That fixed it for me.

doombones's Avatar

11.20.2012 , 08:28 AM | #20
Uhm it doesnt work, the fixer never works.
Still u give that as the first sollution.

Also i added everything in my firewall and my virusscanner.
But i still get the bloody 3003 error as soon as i want to get in any server