Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Ord Mantell - The Ambush STILL BUGGED

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Ord Mantell - The Ambush STILL BUGGED
First BioWare Post First BioWare Post

HazzaTL's Avatar

09.13.2012 , 03:27 PM | #1
I am already past this mission, but decided since it was "fixed" to go back to get it off my mission list..

I spoke to Mirru, that was fine, so was thinking, ah finally.. it's ok now.. but when the communicator came up.. it didn;'t work, tried going to cantina where it worked before and still nothing.. I reset the quest, and was unable to move..

I will not be playing my Trooper til this is fixed once and for all.

Beruthien's Avatar

09.13.2012 , 03:40 PM | #2 This is the last staff post in this thread.  
Greetings HazzaTL,

We are aware of the issues with the mission 'The Ambush' and are working on resolving the issue.

We apologize for any inconvenience this may cause and thank you for your patience as we work to resolve the issue.

Thank you!
Beruthien| BioWare Customer Service Forum Support

AttonStarkiller's Avatar

09.23.2012 , 03:31 AM | #3
From the "Known In-Game Issues: Updated September 21st" post from AmberGreen:

"Trooper: The Ambush: This mission does not complete as intended and remains in the Mission Log after completing the final step to speak to Mirru. The next mission ("Mannet Point") will be granted, and players are able continue with Class story progression.**

** After patch 1.3.7a, players with this issue can contact Customer Support for assistance with completing the mission."

I did contact CS with an in game ticket. I received a generic response and the ticket was closed. I would really just like the mission to be deleted from my log, I am at lvl 27 and have not had any further issues. The thing about this that bothers me is that I have lost an available mission slot of my 25. But the biggest annoyance of this is that whenever I log in my Trooper, I do not get to see the title screen of my current story and chapter. It still lists Prologue and talks about the events surrounding The Ambush mission. After patch 1.3.8 I had tried to go back to Ord Mantell to do the mission again, but I wasn't able to do that.

So my question is, what assistance can Customer Support give me to complete the mission?

AttonStarkiller's Avatar

09.23.2012 , 02:34 PM | #4
I signed in today and my title card is current with my story and "The Ambush" has been removed from my log. Thank you.

HazzaTL's Avatar

10.17.2012 , 05:52 PM | #5
This is STILL in my log..

mdwilliams's Avatar

02.23.2013 , 10:21 PM | #6
Geez, when will this be fixed? I just want the damn thing off my log, but I can't even abandon the quest!

HazzaTL's Avatar

06.05.2013 , 03:26 PM | #7
still waiting..