Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Star Wars the Lag Republic...

First BioWare Post First BioWare Post

Correllius's Avatar


Correllius
07.09.2012 , 03:57 PM | #1
Le titre parle de lui-même... Actuellement ça devient vraiment pénible de jouer et surtout en opération Denova.

Il serait agréable d'avoir des précisions concernant des travaux d'amélioration car pour être franc, c'est le genre de problème qui a tendance à faire fuir une population vers la concurence.

Donc OSEF des distinctions trou noir ou du énième Smourbiff dont tout le monde se fout complétement, par contre le LAG, ça c'est à régler au plus vite.

CharlotteDubois's Avatar


CharlotteDubois
07.09.2012 , 04:23 PM | #2 Click here to go to the next staff post in this thread. Next  
Bonjour Correllius,

Nous essayons en ce moment d'en savoir plus sur les problèmes de latence que connaissent certains d'entre vous. Nous avons lancé un sujet de demandes d'informations ici pour tenter de déterminer ce qui se produit et, s'il s'agit d'un problème de notre part, de le résoudre.

Xhylette's Avatar


Xhylette
07.09.2012 , 04:25 PM | #3
Quote: Originally Posted by Correllius View Post
le LAG, ça c'est à régler au plus vite.
Tu es sûr qu'il s'agit d'un problème de latence ? Le retard de ton serveur se monte à combien ? Tu peux l'obtenir en laissant la souris trainer sur les petites barres au sud-ouest de la mini-carte en bas à droite de l'écran. Là, pour l'instant, j'en suis à 37 ms, mais je joue sur Aldorande ; peu importe d'ailleurs, c'est partout pareil.

La fluidité, c'est tout autre chose. C'est le nombre d'images affichées par seconde (fps), et là, c'est vrai que dans certaines situations, là où il y a du monde, la fluidité n'a plus de fluide que le nom.

Ce problème est connu, archi-connu, depuis le début du jeu. Pour moi, six mois après la sortie du jeu, il n'y a plus aucun espoir de voir ce problème se résoudre par une intervention de l'éditeur. Pour la très simple et très logique raison que si notre éditeur avait pu résoudre ce problème, il y a belle lurette qu'il l'aurait fait. S'il ne le fait pas, c'est qu'il ne le peut pas.

Le problème prend sa source très profondément, au moment de la conception du moteur graphique, il y a cinq ans. Algorithmes simplistes qui surchargent la carte graphique à propos de persos cachés qui ne seront jamais affichés, mais qui sont présents aux alentours, chargements intempestifs de textures qui ne serviront jamais à rien, les problèmes ne manquent pas et ne seront jamais résolus, car il faudrait tout recommencer.

On en est donc réduits à des "soins palliatifs" côté client : une bonne carte graphique avec beaucoup de mémoire, un système d'exploitation 64 bits avec beaucoup de mémoire aussi, le tout bien mis à jour, les préférences graphiques au minimum, un système de ventilation du PC parfaitement propre, et ça finit par passer.

Oui, je sais, j'ai entendu, j'ai compris, c'est injuste, c'est anormal, c'est pas bien de la part de notre éditeur, etc etc ; libre à toi de combattre les moulins à vent, c'est juste de la realpolitik : soit tu t'y fais, soit tu t'y fais pas, c'est un choix ...

Source : --> http://fr.wikipedia.org/wiki/Realpolitik
"Qu'importe la destination, seul compte le voyage."

BarTabak's Avatar


BarTabak
07.10.2012 , 09:01 AM | #4
Xhylette ou l'art de faire des pavés useless...
Est-ce que tu as déjà mis les pieds là bas au moins ? Juste pour savoir. Sinon la latence qui est affichée est le retard client, pas l'inverse. Quand tout le monde freeze pendant une, deux, voir trois secondes et que la latence affichée est entre 30 et 60 ms c'est bien côté serveur le soucis et pas côté client.

Y a des lags sur Denova et c'est pas nouveau. Mais bon c'est juste horrible et injouable pour caler un cycle avec ses sorts. Merci la vague de migration gratuite.

Lexhorn's Avatar


Lexhorn
07.10.2012 , 10:14 AM | #5
J'ai envie de dire OSEF de la latence, mais plutôt OSEF pas des loadings interminables qui font qu'après 3 ou 4 aller retours BG/Planète, le client plante car ma Ram est noyée... J'ai 8 Go portant, il est grands temps qu'ils arrêtent tout ce qu'ils font pour le moment et s’attaquent enfin aux fuites de mémoires qui empêchent les gens de jouer ....
Dans mon temps de jeu d'une heure et demie par jours en moyenne j'ai pas le temps de passer 25 minutes dans les loadings et redémarrage du jeu ...

Aymi's Avatar


Aymi
07.10.2012 , 10:16 AM | #6
Le lag en eu est tout de même un vrai souci et tout le monde n'en fait pas la même expérience. Sur Aion, nous avions eu aussi ce genre de souci et il s'est avéré que les gens concernés avait comme dénominateur commun le meme FAI (en l'occurence Orange ou Free). Peut être à voir dans ce sens égaement ?
Major Fei'lhyn Battle Meditation
Communauté Aegis

Xhylette's Avatar


Xhylette
07.10.2012 , 10:21 AM | #7
Quote: Originally Posted by BarTabak View Post
Xhylette ou l'art de faire des pavés useless... Est-ce que tu as déjà mis les pieds là bas au moins ? Juste pour savoir. Sinon la latence qui est affichée est le retard client, pas l'inverse. Quand tout le monde freeze pendant une, deux, voir trois secondes et que la latence affichée est entre 30 et 60 ms c'est bien côté serveur le soucis et pas côté client.
Non, je n'y ai jamais mis les pieds, mais j'ai beaucoup lu ce qu'ont écrit les doigts de ceux qui y ont mis les mains. Et ils se plaignent, c'est un fait, et plus souvent de saccades à l'affichage que d'une latence élevée.

D'autant, tout à fait entre nous, qu'une latence de 30 ms, c'est cent fois moins que 3 secondes, c'est une excellente connexion dont tout le monde rêve.

Maintenant, l'un n'empêche pas l'autre, évidemment. On peut très bien être affligé à la fois d'une mauvaise fluidité et une latence élevée, comme on peut très bien s'offrir à la fois la rougeole et les oreillons, mais c'est quand même assez rare.


NB. Si plusieurs personnes jouant sur des ordinateurs différents avec des connexions différentes ont tout à coup le même problème sur le jeu lorsqu'elles se retrouvent ensemble quelque part, il faut commencer par rechercher ce qu'elles ont en commun.

Et la seul chose qu'elles ont en commun, c'est le serveur auquel elles sont connectées. Ce ne peut donc être ni un problème de fluidité graphique, ni un problème de latence de connexion, mais très probablement un problème au niveau de leur serveur.
"Qu'importe la destination, seul compte le voyage."

Correllius's Avatar


Correllius
07.10.2012 , 11:55 AM | #8
Quote: Originally Posted by Xhylette View Post
Non, je n'y ai jamais mis les pieds, mais j'ai beaucoup lu ce qu'ont écrit les doigts de ceux qui y ont mis les mains. Et ils se plaignent, c'est un fait, et plus souvent de saccades à l'affichage que d'une latence élevée.
Et oui, tu n'y es jamais allé et tu viens nous faire un beau cours de moral et de je ne sais quoi d'autre à nous pauvres noobs qui n'y connaissons rien en lags, latence graphique ou autre joyeusetés du même acabit... C'est vrai quoi, on n'a qu'à tous changer de PC, optimiser nos réglages etc...

Moi quand je vois environ 64 connectés sur DENOVA dans la soirée, que sur le chat général de DENOVA tout le monde se plaint de la même chose : du lag serveur, je me dis que quelque chose cloche et sans être Sherlock Holmes, je me dis aussi que cela ne vient certainement pas de nos config à tous...

Je remercie d'ailleurs CharlotteDubois d'avoir répondu aussi vite et par la même signalé que le soucis était connu et pris en compte.

A Xhylette je n'ai jamais joué avec toi, mais j'ai beaucoup lu ce qu'ont écrit les doigts de ceux qui ont joué avec toi. Et ils se plaignent, c'est un fait, et plus souvent de : "à compléter par ce qui te passe par la tête."

Allons, faisons preuve de sérieux, ce que je viens d'écrire et pour le moins aussi ridicule que ce que tu as mis dans ton post, à une différence près, je sais que c'est une bêtise...

Xhylette's Avatar


Xhylette
07.10.2012 , 12:18 PM | #9
Le mot anglais "lag" a pour traduction française "retard", mais les joueurs en réseau préfèrent "latence", un mot français, qui n'a pas du tout la signification de "retard", mais celle de "caché" ("A l'état latent").

Quoiqu'il en soit, le "lag" est mesuré sur l'écran du jeu SWTOR, et affiché en bas à droite de l'écran sous l'intitulé "Retard de serveur". C'est encore une fois ambigu, car la valeur affichée n'est pas du tout le temps mis par le serveur pour répondre, mais bien le temps mis par cette réponse à te parvenir, ce qui est tout à fait différent. D'ailleurs, en lisant plus loin, le texte est plus clair : "Cette jauge indique la qualité de votre connexion au serveur de jeu."

Désolé, mais c'est absurde d'accuser les connexions des membres d'un groupe qui rencontrent tout à coup un problème en instance, car il est quasi certain que ces connexions sont différentes. Cela ne peut absolument pas être un problème de lag, surtout quand on cite la valeur de 30 à 50 ms ... c'est clairement un problème de logiciel serveur ou de logiciel client, même Bioware le reconnait.
"Qu'importe la destination, seul compte le voyage."

Correllius's Avatar


Correllius
07.10.2012 , 01:13 PM | #10
Mais lol,

Oui maître Capello, c'est bien ce que je dis, ça vient de SWTOR et pas de nous.