Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Unable to retrieve patch data

STAR WARS: The Old Republic > English > Customer Service
Unable to retrieve patch data
First BioWare Post First BioWare Post

Darthgwar's Avatar


Darthgwar
12.17.2011 , 12:54 AM | #1
When I start the launcher it gets to .07MB remaining of game client 17 then stops and says "Unable to retrieve patch data. Please check network connection. Why do we get messages like this? What the hell network connection am I supposed to check? All I know is I have connectivity to the internet, so why is there a problem?
GAV DARAGON SERVER
J'ayc -- Jedi Guardian Nine -- Sniper Gwar -- Sith Juggernaut M'organ -- Gunslinger Hud'son -- Vanguard F'ilth -- Sith Assassin Mylaa -- Jedi Consular: . Bring back the orange pixel.

Jesishiko_Ketra's Avatar


Jesishiko_Ketra
12.17.2011 , 01:11 AM | #2
Same problem, but the only thing the client complains about is "an error occured updating." Directly wired to the internet and made sure the computer is completely up-to-date. Tried turning off the firewall, etc. NOTHING WORKS.

Game Client 17 doesn't install AT ALL.
"They're using a very primitive dialect, but I do believe they think I am some sort of god."
- C-3PO, Human-Cyborg Relations

tonousas's Avatar


tonousas
12.17.2011 , 04:25 AM | #3
Try changing your dns settings on your lan card to:
8.8.8.8
8.8.4.4
google's dns. worked for me

D6-R8's Avatar


D6-R8
12.17.2011 , 03:37 PM | #4 This is the last staff post in this thread.  


Hi all,

Please check the troubleshooting steps available in this document.

Thank you for your patience.


D6-R8 | BioWare Customer Service - Forum Support

nightinerr's Avatar


nightinerr
12.17.2011 , 04:11 PM | #5
Same issue. I tried using that document, specifically fixing the launcher, and now the launcher freezes while loading my login data, and gives me the same message as in the OP and that I was getting while patching before I even get a chance to type my password.
๘o↾↿▌████████████████████████████████████████)