Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Black screen. Resolution Problems maybe?

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Black screen. Resolution Problems maybe?

Islandborn's Avatar

12.16.2011 , 02:59 PM | #21
Had this problem with black screen here is how I fixed it. First things first do you have dual monitors? The problem with the black screen is the game itself is in a resolution so low that your display can not display it right hence the black screen. It could be that if you have miss matched monitors like I do the game could be detecting the low res one. The best way to get around this is to switch you main monitor to the lower res one and start the game up. It should get in no problem. This is what I did I then set the res to something my main monitor could display and switch it back to being the main one again. No more black screen.

KapitanAwesome's Avatar

12.16.2011 , 03:16 PM | #22
Hey guys, I am NOT Russian, but I do enjoy drinking vodka!!

And I too have the black screen. Changing resolution down to 800x600, or 1280x720 doesn't fix it.

I see a black screen, hear all the sounds, and see my mouse, but I can't do anything except alt-tab of f4 out of the game.

Leterius's Avatar

12.16.2011 , 03:31 PM | #23
Guys I have solved 1 problem just to get another.
The cache error is really only a problem of current profile for me - just create a fake administrator profile on your computer (IMPORTANT: with english letters only) and it ll run cinematics just fine. But now I'm getting game crash right after the first time I cinematic. After this crash the game doesn't even show Bioware logo anymore - just crashes with default windows error: "Appliacation <...> was closed".

Wolfshadowz's Avatar

12.16.2011 , 04:39 PM | #24
Alone you are not
the "cannot display mode" is popping up everywhere many have fixed it with the information here...i have not but i have a back up computer to play on i really hope the problem will be solved by launch,Because despite what some say it is a problem on bioware's end some kind of missing information in the patcher or something.
Update i fixed the problem.
You may have to search for the File in order to access it .