Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Listening to the Quest Giver

STAR WARS: The Old Republic > English > New Player Help
Listening to the Quest Giver

druvokus's Avatar


druvokus
12.15.2011 , 04:46 PM | #1
I'm having a hard time listening to some quest givers while there are blasting noises and other npc's chatting near by ....can this be fixed?

RylanStorm's Avatar


RylanStorm
12.15.2011 , 04:49 PM | #2
There's a slider in the options for music, sound effects, voices etc.
Begun the early access wars have.

-Eternus-'s Avatar


-Eternus-
12.15.2011 , 04:50 PM | #3
Only played one beta weekend and I'm not in yet...so this likely wont help much.

Try lowering sound effects or ambient volume. Not sure what it's actually listed as. Raise voice volume. I'm sure you've done this anyway though. You can always turn subtitles on.

iwakurakaitou's Avatar


iwakurakaitou
12.15.2011 , 04:50 PM | #4
Quote: Originally Posted by RylanStorm View Post
There's a slider in the options for music, sound effects, voices etc.
Wait, like every other video game since 1992?
Mindblowing....
Peace is a Lie, There is only Pudding.

Wapner's Avatar


Wapner
12.15.2011 , 04:51 PM | #5
Quote: Originally Posted by druvokus View Post
I'm having a hard time listening to some quest givers while there are blasting noises and other npc's chatting near by ....can this be fixed?
Go into audio options and turn everything down to like 70%, but leave voices at 100%. It helps.

split_light's Avatar


split_light
12.15.2011 , 04:56 PM | #6
I usually turn on subtitles, which has the added benefit of letting me read ahead if I start getting impatient.

druvokus's Avatar


druvokus
12.15.2011 , 04:56 PM | #7
Quote: Originally Posted by Wapner View Post
Go into audio options and turn everything down to like 70%, but leave voices at 100%. It helps.
Thanks ...I'll have to try that.