Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Logitech G13

Xeranos's Avatar


Xeranos
12.13.2011 , 05:25 PM | #1
How do I get the game to recognize the gamepad?

Thanks
Soon the Republic's failure will be complete... and nothing will stand in the way of the New Empire. ~ Darth Malgus

Felgor's Avatar


Felgor
12.13.2011 , 05:26 PM | #2
Direct it to this...

C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\launcher.exe

Edit: Assuming you have the game installed in the same directory...

Xeranos's Avatar


Xeranos
12.13.2011 , 05:56 PM | #3
Ok... did that, still nothing. Any options in game I have to choose?
Soon the Republic's failure will be complete... and nothing will stand in the way of the New Empire. ~ Darth Malgus

Phumfeinz's Avatar


Phumfeinz
12.13.2011 , 09:10 PM | #4
I'm having the same problem, I can't get my G13 to work in the game at all.
In my opinion.

Phumfeinz's Avatar


Phumfeinz
12.13.2011 , 09:38 PM | #5
Ok I sorted it.

1. Make sure you have the latest GamePanel Software Legacy drivers installed
2. In the key profiler go to Edit>Profile Properties, and choose 'Select using the GamePanel display'.
3. Wait until you're IN THE GAME before hitting accept on your gamepad. Don't do it at the login screen, or any time before that. Only do it when the game has loaded up.

Works for me.
In my opinion.

Aowar's Avatar


Aowar
12.13.2011 , 09:39 PM | #6
They must have changed something. It worked fine in beta without doing anything special.

Gianavel's Avatar


Gianavel
12.14.2011 , 11:26 AM | #7
I've set mine up to point to:

C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient\swtor.exe

That's the program that's actually running the game, and the G13 autodetects and switches quite happily, as does my G700 mouse.

Poha's Avatar


Poha
12.14.2011 , 11:46 AM | #8
Quote: Originally Posted by Gianavel View Post
I've set mine up to point to:

C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\swtor\retailclient\swtor.exe

That's the program that's actually running the game, and the G13 autodetects and switches quite happily, as does my G700 mouse.
I noticed last night that the game (patched from the Thanksgiving beta stress test) now has two ..\retailclient\swtor.exe. I had to select the more recent one for the G13 profile to work, but now it's fine.

Jenorak's Avatar


Jenorak
12.14.2011 , 12:45 PM | #9
Having the same problem. I'll try the above solutions. What do you mean "point to?" Are you talking about the executable?

Gianavel's Avatar


Gianavel
12.14.2011 , 04:39 PM | #10
Quote: Originally Posted by Jenorak View Post
Having the same problem. I'll try the above solutions. What do you mean "point to?" Are you talking about the executable?

Yes.

I need more words.